# CVE-2025-69263: pnpm Lockfile Integrity Bypass Allows Remote Dynamic Dependencies

> Attackers can serve malicious code via HTTP tarball dependencies because pnpm lockfiles lack integrity hashes, compromising supply chain security.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Jan 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-7vhp-vf5g-r2fw, MINI-gp4p-jc2h-52v6

## What is CVE-2025-69263?

CVE-2025-69263 is a high-severity vulnerability in pnpm, published on 7 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

pnpm is a package manager. Versions 10.26.2 and below store HTTP tarball dependencies (and git-hosted tarballs) in the lockfile without integrity hashes. This allows the remote server to serve different content on each install, even when a lockfile is committed. An attacker who publishes a package with an HTTP tarball dependency can serve different code to different users or CI/CD environments. The attack requires the victim to install a package that has an HTTP/git tarball in its dependency tree. The victim's lockfile provides no protection. This issue is fixed in version 10.26.0.

Weakness: CWE-494 (Download of Code Without Integrity Check)

## Which versions are affected by CVE-2025-69263?

2 open source packages ship an affected version, including pnpm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pnpm` | npm | All versions | 10.26.0 |
| `pnpm` | npm | All versions | 10.26.0 |

Products: Pnpm Pnpm.

## How do I fix CVE-2025-69263?

Upgrade pnpm to 10.26.0 or later.

## Is CVE-2025-69263 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69263 exists.

## Other vulnerabilities in pnpm

- [CVE-2026-50016](https://insights.sbomify.com/CVE-2026-50016/): pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement (high 8.8)
- [CVE-2026-55698](https://insights.sbomify.com/CVE-2026-55698/): pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes (high 8.8)
- [CVE-2025-69264](https://insights.sbomify.com/CVE-2025-69264/): pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default" (high 8.8)
- [CVE-2022-26183](https://insights.sbomify.com/CVE-2022-26183/): Untrusted Search Path in PNPM (high 8.8)
- [CVE-2026-59195](https://insights.sbomify.com/CVE-2026-59195/): pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-69263 and fix it if it is affected.

What it is: CVE-2025-69263 is a high-severity vulnerability in pnpm, published on 7 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69263 exists.

Affected packages and fixed versions:
- pnpm (npm): affected all versions; fixed in 10.26.0
- pnpm (npm): affected all versions; fixed in 10.26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-69263/ (Markdown: https://insights.sbomify.com/CVE-2025-69263/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-69263
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-69263
- OSV: https://osv.dev/vulnerability/CVE-2025-69263

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-69263/
Summaries are generated and may contain mistakes; the official description above is the record.
