CVE-2025-69264 pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default"

High 8.8 Published Updated

Attackers can execute arbitrary code via git-hosted dependencies during installation, bypassing pnpm's default script execution restrictions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-69264?

CVE-2025-69264 is a high-severity vulnerability in pnpm, published on 7 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

pnpm is a package manager. Versions 10.0.0 through 10.25 allow git-hosted dependencies to execute arbitrary code during pnpm install, circumventing the v10 security feature "Dependency lifecycle scripts execution disabled by default". While pnpm v10 blocks postinstall scripts via the onlyBuiltDependencies mechanism, git dependencies can still execute prepare, prepublish, and prepack scripts during the fetch phase, enabling remote code execution without user consent or approval. This issue is fixed in version 10.26.0.

Weakness: CWE-693

Which versions are affected by CVE-2025-69264?

2 open source packages ship an affected version, including pnpm. It affects 1 product.

PackageAffectedFixed in
pnpm npmFrom 10.0.010.26.0
pnpm npmFrom 10.0.010.26.0

Products include Pnpm Pnpm.

How do I fix CVE-2025-69264?

Upgrade pnpm to 10.26.0 or later.

Is CVE-2025-69264 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69264 exists.

Sources

Also known as GHSA-379q-355j-w6rj, MINI-95r4-whfj-29j9.

Is CVE-2025-69264 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free