{"answers":{"affected":"2 open source packages ship an affected version, including pnpm. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69264 exists.","fix":"Upgrade pnpm to 10.26.0 or later.","what":"CVE-2025-69264 is a high-severity vulnerability in pnpm, published on 7 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-69264 and fix it if it is affected.\n\nWhat it is: CVE-2025-69264 is a high-severity vulnerability in pnpm, published on 7 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69264 exists.\n\nAffected packages and fixed versions:\n- pnpm (npm): affected from 10.0.0; fixed in 10.26.0\n- pnpm (npm): affected from 10.0.0; fixed in 10.26.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-69264/ (Markdown: https://insights.sbomify.com/CVE-2025-69264/index.md)","id":"CVE-2025-69264","markdown":"https://insights.sbomify.com/CVE-2025-69264/index.md","name":"CVE-2025-69264","record":{"aliases":["GHSA-379q-355j-w6rj","MINI-95r4-whfj-29j9"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"pnpm package manager","requires_auth":"none","summary":"Attackers can execute arbitrary code via git-hosted dependencies during installation, bypassing pnpm's default script execution restrictions.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pnpm","vendor":"pnpm"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-693","name":"Protection Mechanism Failure"}],"description":"pnpm is a package manager. Versions 10.0.0 through 10.25 allow git-hosted dependencies to execute arbitrary code during pnpm install, circumventing the v10 security feature \"Dependency lifecycle scripts execution disabled by default\". While pnpm v10 blocks postinstall scripts via the onlyBuiltDependencies mechanism, git dependencies can still execute prepare, prepublish, and prepack scripts during the fetch phase, enabling remote code execution without user consent or approval. This issue is fixed in version 10.26.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"pnpm v10+ Bypass \"Dependency lifecycle scripts execution disabled by default\"","id":"CVE-2025-69264","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Spectrum directory path traversal","id":"CVE-2025-69267"},"packages":[{"ecosystem":"npm","fixed":["10.26.0"],"introduced":["10.0.0"],"last_affected":[],"package":"pnpm","purl":null,"source":"GHSA-379q-355j-w6rj"},{"ecosystem":"npm","fixed":["10.26.0"],"introduced":["10.0.0"],"last_affected":[],"package":"pnpm","purl":"pkg:npm/pnpm","source":"GHSA-379q-355j-w6rj"}],"prev":{"headline":"pnpm Lockfile Integrity Bypass Allows Remote Dynamic Dependencies","id":"CVE-2025-69263"},"products":["pnpm"],"published":"2026-01-07","related":[{"cvss_score":8.8,"headline":"pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement","id":"CVE-2026-50016","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":8.8,"headline":"pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes","id":"CVE-2026-55698","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":8.8,"headline":"Untrusted Search Path in PNPM","id":"CVE-2022-26183","kev_date_added":null,"published":"2022-03-21"},{"cvss_score":8.2,"headline":"pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config","id":"CVE-2026-59195","kev_date_added":null,"published":"2026-07-06"},{"cvss_score":7.6,"headline":"pnpm vulnerable to Command Injection via environment variable substitution","id":"CVE-2025-69262","kev_date_added":null,"published":"2026-01-07"},{"cvss_score":7.5,"headline":"pnpm: manifest identity spoof satisfies allowBuilds and runs attacker lifecycle","id":"CVE-2026-55487","kev_date_added":null,"published":"2026-06-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-14","vendors":["pnpm"]},"summary":"Attackers can execute arbitrary code via git-hosted dependencies during installation, bypassing pnpm's default script execution restrictions.","url":"https://insights.sbomify.com/CVE-2025-69264/"}