# CVE-2025-69264: pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default"

> Attackers can execute arbitrary code via git-hosted dependencies during installation, bypassing pnpm's default script execution restrictions.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Jan 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-379q-355j-w6rj, MINI-95r4-whfj-29j9

## What is CVE-2025-69264?

CVE-2025-69264 is a high-severity vulnerability in pnpm, published on 7 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

pnpm is a package manager. Versions 10.0.0 through 10.25 allow git-hosted dependencies to execute arbitrary code during pnpm install, circumventing the v10 security feature "Dependency lifecycle scripts execution disabled by default". While pnpm v10 blocks postinstall scripts via the onlyBuiltDependencies mechanism, git dependencies can still execute prepare, prepublish, and prepack scripts during the fetch phase, enabling remote code execution without user consent or approval. This issue is fixed in version 10.26.0.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2025-69264?

2 open source packages ship an affected version, including pnpm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pnpm` | npm | From 10.0.0 | 10.26.0 |
| `pnpm` | npm | From 10.0.0 | 10.26.0 |

Products: Pnpm Pnpm.

## How do I fix CVE-2025-69264?

Upgrade pnpm to 10.26.0 or later.

## Is CVE-2025-69264 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69264 exists.

## Other vulnerabilities in pnpm

- [CVE-2026-50016](https://insights.sbomify.com/CVE-2026-50016/): pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement (high 8.8)
- [CVE-2026-55698](https://insights.sbomify.com/CVE-2026-55698/): pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes (high 8.8)
- [CVE-2022-26183](https://insights.sbomify.com/CVE-2022-26183/): Untrusted Search Path in PNPM (high 8.8)
- [CVE-2026-59195](https://insights.sbomify.com/CVE-2026-59195/): pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config (high 8.2)
- [CVE-2025-69262](https://insights.sbomify.com/CVE-2025-69262/): pnpm vulnerable to Command Injection via environment variable substitution (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-69264 and fix it if it is affected.

What it is: CVE-2025-69264 is a high-severity vulnerability in pnpm, published on 7 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69264 exists.

Affected packages and fixed versions:
- pnpm (npm): affected from 10.0.0; fixed in 10.26.0
- pnpm (npm): affected from 10.0.0; fixed in 10.26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-69264/ (Markdown: https://insights.sbomify.com/CVE-2025-69264/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-69264
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-69264
- OSV: https://osv.dev/vulnerability/CVE-2025-69264

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-69264/
Summaries are generated and may contain mistakes; the official description above is the record.
