CVE-2025-69289 Privilege escalation in discourse

Medium 5.1 Published Updated

Non-admin moderators can take over non-staff accounts by bypassing email change restrictions, requiring an upgrade or configuration change.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-69289?

CVE-2025-69289 is a medium-severity vulnerability in Discourse Discourse, published on 28 Jan 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Discourse is an open source discussion platform. A privilege escalation vulnerability in versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 allows a non-admin moderator to bypass email-change restrictions, allowing a takeover of non-staff accounts. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, ensure moderators are trusted or enable the "require_change_email_confirmation" setting.

Weakness: CWE-863

Which versions are affected by CVE-2025-69289?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.5.4, 2025.11.2, 2025.12.1, 2026.1.0

Products include Discourse Discourse.

How do I fix CVE-2025-69289?

Upgrade discourse to a fixed version for your release line: 3.5.4, 2025.11.2, 2025.12.1 or 2026.1.0.

Is CVE-2025-69289 being exploited?

There is no known exploitation of CVE-2025-69289 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2025-69289, GHSA-p39j-x54c-rwqq.

Is CVE-2025-69289 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free