# CVE-2025-69413: Gitea's /api/v1/user endpoint has different responses for failed authentication depending on whether a username exists

> An attacker can enumerate valid usernames by observing differences in API authentication error responses.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jan 2026
- **Updated:** 5 Jan 2026
- **Also known as:** BIT-gitea-2025-69413, GHSA-pc73-rj2c-wvf9, GO-2026-4274

## What is CVE-2025-69413?

CVE-2025-69413 is a medium-severity vulnerability in Gitea Gitea, published on 1 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Gitea before 1.25.2, /api/v1/user has different responses for failed authentication depending on whether a username exists.

Weakness: CWE-204 (Observable Response Discrepancy)

## Which versions are affected by CVE-2025-69413?

4 open source packages ship an affected version, including code.gitea.io/gitea and gitea. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.gitea.io/gitea` | Go | All versions | 1.25.2 |
| `code.gitea.io/gitea` | Go | All versions | 1.25.2 |
| `code.gitea.io/gitea` | Go | All versions | 1.25.2 |
| `gitea` | Bitnami | All versions | 1.25.2 |

Products: Gitea Gitea.

## How do I fix CVE-2025-69413?

Upgrade code.gitea.io/gitea to 1.25.2 or later.

## Is CVE-2025-69413 being exploited?

There is no known exploitation of CVE-2025-69413 in the wild and no public exploit code.

## Other vulnerabilities in Gitea Gitea

- [CVE-2026-60004](https://insights.sbomify.com/CVE-2026-60004/): Gitea Code Injection (critical 9.8, exploited in the wild)
- [CVE-2026-73278](https://insights.sbomify.com/CVE-2026-73278/): Gitea WebAuthn bypass during OAuth and OIDC sign-in (critical 9.8)
- [CVE-2026-94205](https://insights.sbomify.com/CVE-2026-94205/): Gitea fork workflow approval bypass through maintainer-triggered events (critical 9.8)
- [CVE-2022-42968](https://insights.sbomify.com/CVE-2022-42968/): Gitea vulnerable to Argument Injection (critical 9.8)
- [CVE-2021-45330](https://insights.sbomify.com/CVE-2021-45330/): Improper Privilege Management in Gitea (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-69413 and fix it if it is affected.

What it is: CVE-2025-69413 is a medium-severity vulnerability in Gitea Gitea, published on 1 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-69413 in the wild and no public exploit code.

Affected packages and fixed versions:
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.25.2
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.25.2
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.25.2
- gitea (Bitnami): affected all versions; fixed in 1.25.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-69413/ (Markdown: https://insights.sbomify.com/CVE-2025-69413/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-69413
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-69413
- OSV: https://osv.dev/vulnerability/CVE-2025-69413

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-69413/
Summaries are generated and may contain mistakes; the official description above is the record.
