CVE-2025-6945 Improper Neutralization of Special Elements used in a Command ('Command Injection') in GitLab

Low 3.5 Published Updated

Authenticated attackers can leak sensitive information from confidential issues by injecting hidden prompts into merge request comments in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-6945?

CVE-2025-6945 is a low-severity command injection vulnerability in Gitlab Gitlab, published on 15 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 17.8 before 18.3.6, 18.4 before 18.4.4, and 18.5 before 18.5.2 that could have allowed an authenticated attacker to leak sensitive information from confidential issues by injecting hidden prompts into merge request comments.

Weakness: CWE-77

Which versions are affected by CVE-2025-6945?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 17.8.018.3.6, 18.4.4, 18.5.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-6945?

Upgrade gitlab to a fixed version for your release line: 18.3.6, 18.4.4 or 18.5.2.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2025-6945 being exploited?

There is no known exploitation of CVE-2025-6945 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-6945, GHSA-r22j-98fp-4fw9, UBUNTU-CVE-2025-6945.

Is CVE-2025-6945 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free