CVE-2025-69534 Python-Markdown has an Uncaught Exception
Remote attackers can crash applications parsing untrusted Markdown via unhandled exceptions, causing denial of service and potential information disclosure.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-69534?
CVE-2025-69534 is a high-severity denial of service vulnerability in n/a, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Python-Markdown version 3.8 contain a vulnerability where malformed HTML-like sequences can cause html.parser.HTMLParser to raise an unhandled AssertionError during Markdown parsing. Because Python-Markdown does not catch this exception, any application that processes attacker-controlled Markdown may crash. This enables remote, unauthenticated Denial of Service in web applications, documentation systems, CI/CD pipelines, and any service that renders untrusted Markdown. The issue was acknowledged by the vendor and fixed in version 3.8.1. This issue causes a remote Denial of Service in any application parsing untrusted Markdown, and can lead to Information Disclosure through uncaught exceptions.
Which versions are affected by CVE-2025-69534?
3 open source packages ship an affected version, including markdown and Markdown. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
markdown PyPI | All versions to 3.8 | None |
markdown PyPI | All versions | 3.8.1 |
Markdown PyPI | All versions | 3.8.1 |
Linux distribution packages (15)
python3-markdown AlmaLinux:10 | All versions | 3.5.1-6.el10_2.1 |
python3-markdown AlmaLinux:9 | All versions | 3.3.4-4.el9_8.2 |
python-markdown Red Hat:enterprise_linux:10.2 | All versions | 0:3.5.1-6.el10_2.1 |
python3-markdown Red Hat:enterprise_linux:10.2 | All versions | 0:3.5.1-6.el10_2.1 |
python-markdown Red Hat:enterprise_linux:9::baseos | All versions | 0:3.3.4-4.el9_8.2 |
python3-markdown Red Hat:enterprise_linux:9::baseos | All versions | 0:3.3.4-4.el9_8.2 |
python-markdown Red Hat:enterprise_linux_eus:10.0 | All versions | 0:3.5.1-6.el10_0.1 |
python3-markdown Red Hat:enterprise_linux_eus:10.0 | All versions | 0:3.5.1-6.el10_0.1 |
python-markdown Red Hat:rhel_eus:9.4::baseos | All versions | 0:3.3.4-4.el9_4.2 |
python3-markdown Red Hat:rhel_eus:9.4::baseos | All versions | 0:3.3.4-4.el9_4.2 |
python-markdown Red Hat:rhel_eus:9.6::baseos | All versions | 0:3.3.4-4.el9_6.2 |
python3-markdown Red Hat:rhel_eus:9.6::baseos | All versions | 0:3.3.4-4.el9_6.2 |
python-markdown Rocky Linux:10 | All versions | 0:3.5.1-6.el10_2.1 |
python-markdown Rocky Linux:9 | All versions | 0:3.3.4-4.el9_8.2 |
python-Markdown openSUSE:Leap 15.6 | All versions | 3.5.2-150600.3.3.1 |
Products include Python-Markdown Markdown.
How do I fix CVE-2025-69534?
Upgrade markdown to 3.8.1 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-69534 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69534 exists.
Sources
Also known as ALSA-2026:19155, ALSA-2026:19366, BELL-CVE-2025-69534, CLSA-2026-1785886363, CLSA-2026-1786489323, DEBIAN-CVE-2025-69534 and 20 more.