# CVE-2025-69534: Python-Markdown has an Uncaught Exception

> Remote attackers can crash applications parsing untrusted Markdown via unhandled exceptions, causing denial of service and potential information disclosure.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2026
- **Updated:** 7 Sep 2026
- **Also known as:** ALSA-2026:19155, ALSA-2026:19366, BELL-CVE-2025-69534, CLSA-2026-1785886363, CLSA-2026-1786489323, DEBIAN-CVE-2025-69534, ECHO-3e8b-d85e-69ba, GHSA-5wmx-573v-2qwq, MINI-q492-jgp3-8qx2, OESA-2026-1787, OESA-2026-1788, OESA-2026-1789, OESA-2026-1790, PYSEC-2026-89, RHSA-2026:19155, RHSA-2026:19366, RHSA-2026:20674, RHSA-2026:20676, RHSA-2026:20677, RLSA-2026:19155, RLSA-2026:19366, ROOT-APP-PYPI-CVE-2025-69534, ROOT-OS-DEBIAN-11-CVE-2025-69534, ROOT-OS-DEBIAN-12-CVE-2025-69534, SUSE-SU-2026:0846-1, UBUNTU-CVE-2025-69534

## What is CVE-2025-69534?

CVE-2025-69534 is a high-severity denial of service vulnerability in n/a, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Python-Markdown version 3.8 contain a vulnerability where malformed HTML-like sequences can cause html.parser.HTMLParser to raise an unhandled AssertionError during Markdown parsing. Because Python-Markdown does not catch this exception, any application that processes attacker-controlled Markdown may crash. This enables remote, unauthenticated Denial of Service in web applications, documentation systems, CI/CD pipelines, and any service that renders untrusted Markdown. The issue was acknowledged by the vendor and fixed in version 3.8.1. This issue causes a remote Denial of Service in any application parsing untrusted Markdown, and can lead to Information Disclosure through uncaught exceptions.

Weakness: CWE-617 (Reachable Assertion), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-69534?

3 open source packages ship an affected version, including markdown and Markdown. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `markdown` | PyPI | All versions to 3.8 | None |
| `markdown` | PyPI | All versions | 3.8.1 |
| `Markdown` | PyPI | All versions | 3.8.1 |
| `python3-markdown` | AlmaLinux:10 | All versions | 3.5.1-6.el10_2.1 |
| `python3-markdown` | AlmaLinux:9 | All versions | 3.3.4-4.el9_8.2 |
| `python-markdown` | Red Hat:enterprise_linux:10.2 | All versions | 0:3.5.1-6.el10_2.1 |
| `python3-markdown` | Red Hat:enterprise_linux:10.2 | All versions | 0:3.5.1-6.el10_2.1 |
| `python-markdown` | Red Hat:enterprise_linux:9::baseos | All versions | 0:3.3.4-4.el9_8.2 |
| `python3-markdown` | Red Hat:enterprise_linux:9::baseos | All versions | 0:3.3.4-4.el9_8.2 |
| `python-markdown` | Red Hat:enterprise_linux_eus:10.0 | All versions | 0:3.5.1-6.el10_0.1 |
| `python3-markdown` | Red Hat:enterprise_linux_eus:10.0 | All versions | 0:3.5.1-6.el10_0.1 |
| `python-markdown` | Red Hat:rhel_eus:9.4::baseos | All versions | 0:3.3.4-4.el9_4.2 |
| `python3-markdown` | Red Hat:rhel_eus:9.4::baseos | All versions | 0:3.3.4-4.el9_4.2 |
| `python-markdown` | Red Hat:rhel_eus:9.6::baseos | All versions | 0:3.3.4-4.el9_6.2 |
| `python3-markdown` | Red Hat:rhel_eus:9.6::baseos | All versions | 0:3.3.4-4.el9_6.2 |
| `python-markdown` | Rocky Linux:10 | All versions | 0:3.5.1-6.el10_2.1 |
| `python-markdown` | Rocky Linux:9 | All versions | 0:3.3.4-4.el9_8.2 |
| `python-Markdown` | openSUSE:Leap 15.6 | All versions | 3.5.2-150600.3.3.1 |

Products: Python-Markdown Markdown.

## How do I fix CVE-2025-69534?

Upgrade markdown to 3.8.1 or later.

## Is CVE-2025-69534 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69534 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-69534 and fix it if it is affected.

What it is: CVE-2025-69534 is a high-severity denial of service vulnerability in n/a, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69534 exists.

Affected packages and fixed versions:
- markdown (PyPI): affected all versions up to 3.8; no fix listed
- markdown (PyPI): affected all versions; fixed in 3.8.1
- Markdown (PyPI): affected all versions; fixed in 3.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-69534/ (Markdown: https://insights.sbomify.com/CVE-2025-69534/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-69534
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-69534
- OSV: https://osv.dev/vulnerability/CVE-2025-69534

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-69534/
Summaries are generated and may contain mistakes; the official description above is the record.
