CVE-2025-69633 SQL injection in n/a
Remote unauthenticated attackers can execute arbitrary SQL queries via the fromController parameter in the Advanced Popup Creator PrestaShop plugin.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-69633?
CVE-2025-69633 is a critical SQL injection vulnerability in n/a, published on 13 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A SQL Injection vulnerability in the Advanced Popup Creator (advancedpopupcreator) module for PrestaShop 1.1.26 through 1.2.6 (Fixed in version 1.2.7) allows remote unauthenticated attackers to execute arbitrary SQL queries via the fromController parameter in the popup controller. The parameter is passed unsanitized to SQL queries in classes/AdvancedPopup.php (getPopups() and updateVisits() functions).
Weakness: CWE-89
Which versions are affected by CVE-2025-69633?
How do I fix CVE-2025-69633?
No fix has been published for CVE-2025-69633 yet. Limit exposure of the affected software until one is available.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2025-69633 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69633 exists.
Sources
Also known as GHSA-7vwv-5gmf-fwq5.