{"answers":{"affected":"3 open source packages ship an affected version, including geopandas. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69662 exists.","fix":"Upgrade geopandas to 1.1.2 or later.","what":"CVE-2025-69662 is a high-severity SQL injection vulnerability in n/a, published on 30 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-69662 and fix it if it is affected.\n\nWhat it is: CVE-2025-69662 is a high-severity SQL injection vulnerability in n/a, published on 30 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69662 exists.\n\nAffected packages and fixed versions:\n- geopandas (PyPI): affected all versions; fixed in 1.1.2\n- geopandas (PyPI): affected all versions; fixed in 1.1.2\n- geopandas (PyPI): affected all versions; fixed in 1.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-69662/ (Markdown: https://insights.sbomify.com/CVE-2025-69662/index.md)","id":"CVE-2025-69662","markdown":"https://insights.sbomify.com/CVE-2025-69662/index.md","name":"CVE-2025-69662","record":{"aliases":["DEBIAN-CVE-2025-69662","GHSA-6497-prx7-gpmq","PYSEC-2026-62","UBUNTU-CVE-2025-69662","USN-8083-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python geospatial library","requires_auth":"none","summary":"An attacker can obtain sensitive information via SQL injection in the to_postgis function of the geopandas library.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"geopandas","vendor":"geopandas"}],"cvss":{"score":8.6,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"SQL injection vulnerability in geopandas before v.1.1.2 allows an attacker to obtain sensitive information via the to_postgis()` function being used to write GeoDataFrames to a PostgreSQL database.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"geopandas SQL Injection Vulnerability in to_postgis() Allows Information Disclosure","id":"CVE-2025-69662","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"sql_injection","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Memory corruption in n/a","id":"CVE-2025-69674"},"packages":[{"ecosystem":"PyPI","fixed":["1.1.2"],"introduced":["0"],"last_affected":[],"package":"geopandas","purl":null,"source":"GHSA-6497-prx7-gpmq"},{"ecosystem":"PyPI","fixed":["1.1.2"],"introduced":["0"],"last_affected":[],"package":"geopandas","purl":"pkg:pypi/geopandas","source":"GHSA-6497-prx7-gpmq"},{"ecosystem":"PyPI","fixed":["1.1.2"],"introduced":["0"],"last_affected":[],"package":"geopandas","purl":"pkg:pypi/geopandas","source":"PYSEC-2026-62"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2025-69654"},"products":["n/a"],"published":"2026-01-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-21","vendors":["n/a"]},"summary":"An attacker can obtain sensitive information via SQL injection in the to_postgis function of the geopandas library.","url":"https://insights.sbomify.com/CVE-2025-69662/"}