# CVE-2025-6977: Cross-site scripting in ProfileGrid – User Profiles, Groups and Communities

> Unauthenticated attackers can inject arbitrary scripts via a crafted link, potentially compromising logged-in users of the ProfileGrid WordPress plugin.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 16 Jul 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-q46q-h5wj-c8cp

## What is CVE-2025-6977?

CVE-2025-6977 is a medium-severity cross-site scripting vulnerability in metagauss ProfileGrid – User Profiles, Groups and Communities, published on 16 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The ProfileGrid – User Profiles, Groups and Communities plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘pm_get_messenger_notification’ function in all versions up to, and including, 5.9.5.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a logged-in user into performing an action such as clicking on a link.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-6977?

It affects 1 product.


Products: Metagauss Profilegrid.

## How do I fix CVE-2025-6977?

No fix has been published for CVE-2025-6977 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-6977 being exploited?

There is no known exploitation of CVE-2025-6977 in the wild and no public exploit code.

## Other vulnerabilities in metagauss ProfileGrid – User Profiles, Groups and Communities

- [CVE-2024-30490](https://insights.sbomify.com/CVE-2024-30490/): WordPress ProfileGrid plugin <= 5.7.8 - SQL Injection vulnerability (critical 9.3)
- [CVE-2025-0724](https://insights.sbomify.com/CVE-2025-0724/): ProfileGrid – User Profiles, Groups and Communities <= 5.9.4.5 - Authenticated (Subscriber+) PHP Object Injection (high 8.8)
- [CVE-2024-6411](https://insights.sbomify.com/CVE-2024-6411/): Privilege escalation in ProfileGrid – User Profiles, Groups and Communities (high 8.8)
- [CVE-2023-3713](https://insights.sbomify.com/CVE-2023-3713/): ProfileGrid <= 5.5.1 - Authenticated (Subscriber+) Arbitrary Option Update (high 8.8)
- [CVE-2023-0940](https://insights.sbomify.com/CVE-2023-0940/): ProfileGrid < 5.3.1 - Subscriber+ Arbitrary Password Reset (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6977 and fix it if it is affected.

What it is: CVE-2025-6977 is a medium-severity cross-site scripting vulnerability in metagauss ProfileGrid – User Profiles, Groups and Communities, published on 16 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-6977 in the wild and no public exploit code.

Affected product: metagauss ProfileGrid – User Profiles, Groups and Communities. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6977/ (Markdown: https://insights.sbomify.com/CVE-2025-6977/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6977
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6977
- OSV: https://osv.dev/vulnerability/CVE-2025-6977

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6977/
Summaries are generated and may contain mistakes; the official description above is the record.
