CVE-2025-6981 Missing authorization in Enterprise Server

Medium 5.3 Published Updated

Unauthorized users could read internal repository contents via the Contractors API when this rarely-enabled feature was active.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-6981?

CVE-2025-6981 is a medium-severity missing authorization vulnerability in Github Enterprise Server, published on 15 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An incorrect authorization vulnerability allowed unauthorized read access to the contents of internal repositories for contractor accounts when the Contractors API feature was enabled. The Contractors API is a rarely-enabled feature in private preview. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.18 and was fixed in versions 3.14.15, 3.15.10, 3.16.6 and 3.17.3

Weakness: CWE-863

Which versions are affected by CVE-2025-6981?

It affects 1 product.

Products include Github Enterprise Server.

How do I fix CVE-2025-6981?

No fix has been published for CVE-2025-6981 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-6981 being exploited?

There is no known exploitation of CVE-2025-6981 in the wild and no public exploit code.

All Github Enterprise Server vulnerabilities

Sources

Also known as GHSA-68h4-89v6-8m3j.

Is CVE-2025-6981 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free