{"answers":{"affected":"3 open source packages ship an affected version, including langchain-community.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6984 exists.","fix":"Upgrade langchain-community to 0.3.27 or later.","what":"CVE-2025-6984 is a high-severity vulnerability in langchain-ai/langchain, published on 4 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-6984 and fix it if it is affected.\n\nWhat it is: CVE-2025-6984 is a high-severity vulnerability in langchain-ai/langchain, published on 4 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6984 exists.\n\nAffected packages and fixed versions:\n- langchain-community (PyPI): affected all versions; fixed in 0.3.27\n- langchain-community (PyPI): affected all versions; fixed in 0.3.27\n- langchain-community (PyPI): affected all versions; fixed in 0.3.27\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-6984/ (Markdown: https://insights.sbomify.com/CVE-2025-6984/index.md)","id":"CVE-2025-6984","markdown":"https://insights.sbomify.com/CVE-2025-6984/index.md","name":"CVE-2025-6984","record":{"aliases":["GHSA-pc6w-59fv-rh23","PYSEC-2026-1515"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python AI library","requires_auth":"none","summary":"Attackers can exploit insecure XML parsing in EverNoteLoader to disclose sensitive local files via XXE attacks.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"The langchain-ai/langchain project, specifically the EverNoteLoader component, is vulnerable to XML External Entity (XXE) attacks due to insecure XML parsing. The affected version is 0.3.63. The vulnerability arises from the use of etree.iterparse() without disabling external entity references, which can lead to sensitive information disclosure. An attacker could exploit this by crafting a malicious XML payload that references local files, potentially exposing sensitive data such as /etc/passwd.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Sensitive Information Disclosure Due to Insecure XML Parsing in langchain-ai/langchain","id":"CVE-2025-6984","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xxe","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"XXE Vulnerability in langchain-ai/langchain","id":"CVE-2025-6985"},"packages":[{"ecosystem":"PyPI","fixed":["0.3.27"],"introduced":["0"],"last_affected":[],"package":"langchain-community","purl":null,"source":"GHSA-pc6w-59fv-rh23"},{"ecosystem":"PyPI","fixed":["0.3.27"],"introduced":["0"],"last_affected":[],"package":"langchain-community","purl":"pkg:pypi/langchain-community","source":"GHSA-pc6w-59fv-rh23"},{"ecosystem":"PyPI","fixed":["0.3.27"],"introduced":["0"],"last_affected":[],"package":"langchain-community","purl":"pkg:pypi/langchain-community","source":"PYSEC-2026-1515"}],"prev":{"headline":"Clickjacking vulnerability on the management web application of TP-LINK Archer C1200","id":"CVE-2025-6983"},"products":["langchain-ai/langchain"],"published":"2025-09-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-04","vendors":["langchain-ai"]},"summary":"Attackers can exploit insecure XML parsing in EverNoteLoader to disclose sensitive local files via XXE attacks.","url":"https://insights.sbomify.com/CVE-2025-6984/"}