# CVE-2025-6984: Sensitive Information Disclosure Due to Insecure XML Parsing in langchain-ai/langchain

> Attackers can exploit insecure XML parsing in EverNoteLoader to disclose sensitive local files via XXE attacks.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2025
- **Updated:** 4 Sep 2025
- **Also known as:** GHSA-pc6w-59fv-rh23, PYSEC-2026-1515

## What is CVE-2025-6984?

CVE-2025-6984 is a high-severity vulnerability in langchain-ai/langchain, published on 4 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The langchain-ai/langchain project, specifically the EverNoteLoader component, is vulnerable to XML External Entity (XXE) attacks due to insecure XML parsing. The affected version is 0.3.63. The vulnerability arises from the use of etree.iterparse() without disabling external entity references, which can lead to sensitive information disclosure. An attacker could exploit this by crafting a malicious XML payload that references local files, potentially exposing sensitive data such as /etc/passwd.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-6984?

3 open source packages ship an affected version, including langchain-community.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langchain-community` | PyPI | All versions | 0.3.27 |
| `langchain-community` | PyPI | All versions | 0.3.27 |
| `langchain-community` | PyPI | All versions | 0.3.27 |

## How do I fix CVE-2025-6984?

Upgrade langchain-community to 0.3.27 or later.

## Is CVE-2025-6984 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6984 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6984 and fix it if it is affected.

What it is: CVE-2025-6984 is a high-severity vulnerability in langchain-ai/langchain, published on 4 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6984 exists.

Affected packages and fixed versions:
- langchain-community (PyPI): affected all versions; fixed in 0.3.27
- langchain-community (PyPI): affected all versions; fixed in 0.3.27
- langchain-community (PyPI): affected all versions; fixed in 0.3.27

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6984/ (Markdown: https://insights.sbomify.com/CVE-2025-6984/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6984
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6984
- OSV: https://osv.dev/vulnerability/CVE-2025-6984

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6984/
Summaries are generated and may contain mistakes; the official description above is the record.
