# CVE-2025-6985: XXE Vulnerability in langchain-ai/langchain

> Remote attackers can read arbitrary local files via XXE in HTMLSectionSplitter when custom XSLT is enabled.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2025
- **Updated:** 6 Oct 2025
- **Also known as:** GHSA-m42m-m8cr-8m58, PYSEC-2026-1520, ROOT-APP-PYPI-CVE-2025-6985

## What is CVE-2025-6985?

CVE-2025-6985 is a high-severity vulnerability in langchain-ai/langchain, published on 6 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The HTMLSectionSplitter class in langchain-text-splitters version 0.3.8 is vulnerable to XML External Entity (XXE) attacks due to unsafe XSLT parsing. This vulnerability arises because the class allows the use of arbitrary XSLT stylesheets, which are parsed using lxml.etree.parse() and lxml.etree.XSLT() without any hardening measures. In lxml versions up to 4.9.x, external entities are resolved by default, allowing attackers to read arbitrary local files or perform outbound HTTP(S) fetches. In lxml versions 5.0 and above, while entity expansion is disabled, the XSLT document() function can still read any URI unless XSLTAccessControl is applied. This vulnerability allows remote attackers to gain read-only access to any file the LangChain process can reach, including sensitive files such as SSH keys, environment files, source code, or cloud metadata. No authentication, special privileges, or user interaction are required, and the issue is exploitable in default deployments that enable custom XSLT.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2025-6985?

3 open source packages ship an affected version, including langchain-text-splitters.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langchain-text-splitters` | PyPI | All versions | 0.3.9 |
| `langchain-text-splitters` | PyPI | All versions | 0.3.9 |
| `langchain-text-splitters` | PyPI | All versions | 0.3.9 |

## How do I fix CVE-2025-6985?

Upgrade langchain-text-splitters to 0.3.9 or later.

## Is CVE-2025-6985 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6985 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6985 and fix it if it is affected.

What it is: CVE-2025-6985 is a high-severity vulnerability in langchain-ai/langchain, published on 6 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6985 exists.

Affected packages and fixed versions:
- langchain-text-splitters (PyPI): affected all versions; fixed in 0.3.9
- langchain-text-splitters (PyPI): affected all versions; fixed in 0.3.9
- langchain-text-splitters (PyPI): affected all versions; fixed in 0.3.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6985/ (Markdown: https://insights.sbomify.com/CVE-2025-6985/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6985
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6985
- OSV: https://osv.dev/vulnerability/CVE-2025-6985

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6985/
Summaries are generated and may contain mistakes; the official description above is the record.
