{"answers":{"affected":"4 open source packages ship an affected version, including ajv.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69873 exists.","fix":"Upgrade ajv to a fixed version for your release line: 6.14.0 or 8.18.0.","what":"CVE-2025-69873 is a low-severity denial of service vulnerability in ajv.js ajv, published on 11 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-69873 and fix it if it is affected.\n\nWhat it is: CVE-2025-69873 is a low-severity denial of service vulnerability in ajv.js ajv, published on 11 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69873 exists.\n\nAffected packages and fixed versions:\n- ajv (npm): affected all versions; fixed in 6.14.0\n- ajv (npm): affected all versions; fixed in 6.14.0\n- ajv (npm): affected from 7.0.0-alpha.0; fixed in 8.18.0\n- ajv (npm): affected from 7.0.0-alpha.0; fixed in 8.18.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-69873/ (Markdown: https://insights.sbomify.com/CVE-2025-69873/index.md)","id":"CVE-2025-69873","markdown":"https://insights.sbomify.com/CVE-2025-69873/index.md","name":"CVE-2025-69873","record":{"aliases":["CLEANSTART-2026-LI51874","CLEANSTART-2026-NS67921","CLEANSTART-2026-VM51396","CLSA-2026-1773015259","CLSA-2026-1773015260","CLSA-2026-1773015261","CLSA-2026-1774570946","CLSA-2026-1774916723","CLSA-2026-1775003172","CLSA-2026-1776818196","CLSA-2026-1779151627","CLSA-2026-1779151633","CLSA-2026-1787001707","CLSA-2026-1790161390","CLSA-2026-1790763286","CLSA-2026-1792488470","CLSA-2026-1792766110","CLSA-2026-1793046415","CLSA-2026-1793097555","DEBIAN-CVE-2025-69873","ECHO-c323-b788-63cc","GHSA-2g4f-4pwh-qvx6","MINI-2gwc-jxv7-h24v","MINI-448w-f589-rg5h","MINI-4crg-6wjr-x62f","MINI-5xx9-4jrq-8jmc","MINI-6622-wmw4-rf96","MINI-6c7m-qxj8-5pcr","MINI-6xr3-26qw-q3mg","MINI-747g-rw5m-wpm5","MINI-78rc-7x4w-xrfx","MINI-7v47-cp6c-6q28","MINI-7vxw-945h-56cg","MINI-c5hp-x8pj-g848","MINI-c7wg-797g-5q9q","MINI-cpjw-97vr-8v5f","MINI-f3hg-8pmh-hfgj","MINI-g4wm-hx7q-h67w","MINI-gp8g-hgmr-2h58","MINI-hc68-49vj-v2mr","MINI-jvwf-gm26-627g","MINI-p2m7-mqwj-2h6w","MINI-p4r6-6xg7-j9m4","MINI-pwgr-46qq-76rh","MINI-q4g2-jv69-5r8w","MINI-qg7m-g97f-x8pm","MINI-qj6g-7h42-xf34","MINI-vqgh-hhrm-4x6p","MINI-w66h-h363-6wmx","ROOT-APP-NPM-CVE-2025-69873","UBUNTU-CVE-2025-69873"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"JavaScript JSON validator","requires_auth":"none","summary":"Attackers can cause denial of service via catastrophic backtracking in ajv when the $data option is enabled, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":2.9,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"},{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"ajv (Another JSON Schema Validator) before 8.18.0 is vulnerable to Regular Expression Denial of Service (ReDoS) when the $data option is enabled. The pattern keyword accepts runtime data via JSON Pointer syntax ($data reference), which is passed directly to the JavaScript RegExp() constructor without validation. An attacker can inject a malicious regex pattern (e.g., \"^(a|a)*$\") combined with crafted input to cause catastrophic backtracking. A 31-character payload causes approximately 44 seconds of CPU blocking, with each additional character doubling execution time. This enables complete denial of service with a single HTTP request against any API using ajv with $data: true for dynamic schema validation. This issue is also fixed in version 6.14.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"ajv has ReDoS when using `$data` option","id":"CVE-2025-69873","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":4,"n_references":6,"next":{"headline":"nanotar is vulnerable to path traversal in parseTar() and parseTarGzip()","id":"CVE-2025-69874"},"packages":[{"ecosystem":"npm","fixed":["6.14.0"],"introduced":["0"],"last_affected":[],"package":"ajv","purl":null,"source":"GHSA-2g4f-4pwh-qvx6"},{"ecosystem":"npm","fixed":["6.14.0"],"introduced":["0"],"last_affected":[],"package":"ajv","purl":"pkg:npm/ajv","source":"GHSA-2g4f-4pwh-qvx6"},{"ecosystem":"npm","fixed":["8.18.0"],"introduced":["7.0.0-alpha.0"],"last_affected":[],"package":"ajv","purl":null,"source":"GHSA-2g4f-4pwh-qvx6"},{"ecosystem":"npm","fixed":["8.18.0"],"introduced":["7.0.0-alpha.0"],"last_affected":[],"package":"ajv","purl":"pkg:npm/ajv","source":"GHSA-2g4f-4pwh-qvx6"}],"prev":{"headline":"DiskCache has unsafe pickle deserialization","id":"CVE-2025-69872"},"products":["ajv"],"published":"2026-02-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-14","vendors":["ajv.js"]},"summary":"Attackers can cause denial of service via catastrophic backtracking in ajv when the $data option is enabled, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2025-69873/"}