# CVE-2025-69971: FUXA has a hardcoded fallback JWT signing secret

> Remote attackers can forge admin tokens using a hard-coded secret to bypass authentication and gain full administrative access to FUXA.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Feb 2026
- **Updated:** 28 Feb 2026
- **Also known as:** GHSA-c8m8-3jcr-6rj5

## What is CVE-2025-69971?

CVE-2025-69971 is a critical vulnerability in n/a, published on 3 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FUXA v1.2.7 contains a hard-coded credential vulnerability in server/api/jwt-helper.js. The application uses a hard-coded secret key to sign and verify JWT Tokens. This allows remote attackers to forge valid admin tokens and bypass authentication to gain full administrative access.

Weakness: CWE-798 (Use of Hard-coded Credentials)

## Which versions are affected by CVE-2025-69971?

2 open source packages ship an affected version, including @frangoteam/fuxa. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@frangoteam/fuxa` | npm | All versions | 1.3.0 |
| `@frangoteam/fuxa` | npm | All versions | 1.3.0 |

Products: Frangoteam Fuxa.

## How do I fix CVE-2025-69971?

Upgrade @frangoteam/fuxa to 1.3.0 or later.

## Is CVE-2025-69971 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69971 exists.

Public exploit code:

- FUXA <= 1.2.7 - Hardcoded JWT Secret Authentication Bypass (nuclei): http/cves/2025/CVE-2025-69971.yaml

## Other vulnerabilities in n/a

- [CVE-2026-25893](https://insights.sbomify.com/CVE-2026-25893/): FUXA Unauthenticated Remote Code Execution via Admin JWT Minting (critical 10.0)
- [CVE-2025-69985](https://insights.sbomify.com/CVE-2025-69985/): FUXA has JWT Authentication Bypass via HTTP Referer header spoofing (critical 9.8)
- [CVE-2023-31719](https://insights.sbomify.com/CVE-2023-31719/): FUXA SQL Injection vulnerability (critical 9.8)
- [CVE-2023-33831](https://insights.sbomify.com/CVE-2023-33831/): A remote command execution (RCE) vulnerability in the /api/runscript endpoint of FUXA (critical 9.8)
- [CVE-2026-25894](https://insights.sbomify.com/CVE-2026-25894/): FUXA Unauthenticated Remote Code Execution via Hardcoded JWT Secret in Default Configuration (critical 9.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-69971 and fix it if it is affected.

What it is: CVE-2025-69971 is a critical vulnerability in n/a, published on 3 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-69971 exists.

Affected packages and fixed versions:
- @frangoteam/fuxa (npm): affected all versions; fixed in 1.3.0
- @frangoteam/fuxa (npm): affected all versions; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-69971/ (Markdown: https://insights.sbomify.com/CVE-2025-69971/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-69971
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-69971
- OSV: https://osv.dev/vulnerability/CVE-2025-69971

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-69971/
Summaries are generated and may contain mistakes; the official description above is the record.
