CVE-2025-7001 Insufficient Granularity of Access Control in GitLab
Privileged users can access restricted resource group information via the API due to insufficient access control granularity.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-7001?
CVE-2025-7001 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 24 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab CE/EE affecting all versions from 15.0 before 18.0.5, 18.1 before 18.1.3, and 18.2 before 18.2.1 that could have allowed priviledged users to access certain resource_group information through the API which should have been unavailable.
Weakness: CWE-1220
Which versions are affected by CVE-2025-7001?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 15.0.0 | 18.0.5, 18.1.3, 18.2.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2025-7001?
Upgrade gitlab to a fixed version for your release line: 18.0.5, 18.1.3 or 18.2.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-7001 being exploited?
There is no known exploitation of CVE-2025-7001 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2025-7001, GHSA-w44h-qxhv-wqww, UBUNTU-CVE-2025-7001.