{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-70067 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-70067 is a critical memory corruption vulnerability in n/a, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-70067 and fix it if it is affected.\n\nWhat it is: CVE-2025-70067 is a critical memory corruption vulnerability in n/a, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-70067 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-70067/ (Markdown: https://insights.sbomify.com/CVE-2025-70067/index.md)","id":"CVE-2025-70067","markdown":"https://insights.sbomify.com/CVE-2025-70067/index.md","name":"CVE-2025-70067","record":{"aliases":["DEBIAN-CVE-2025-70067","GHSA-r3jc-f37h-j289","UBUNTU-CVE-2025-70067","openSUSE-SU-2026:10739-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"3D model import library","requires_auth":"none","summary":"A buffer overflow in the Assimp FBX importer allows attackers to execute arbitrary code or cause denial of service via crafted files.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"Buffer Overflow vulnerability exists in Assimp versions up to 6.0.2 in the FBX Importer. The vulnerability occurs in aiMaterial::AddBinaryProperty, where a property key string from a crafted FBX file is copied into a fixed-size heap buffer using strcpy() without runtime length validation","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2025-70067","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":1,"n_references":2,"next":{"headline":"Denial of service in n/a","id":"CVE-2025-70069"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["6.0.5-2.1"],"introduced":["0"],"last_affected":[],"package":"assimp","purl":"pkg:rpm/opensuse/assimp\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10739-1"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2025-70064"},"products":["n/a"],"published":"2026-05-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-05","vendors":["n/a"]},"summary":"A buffer overflow in the Assimp FBX importer allows attackers to execute arbitrary code or cause denial of service via crafted files.","url":"https://insights.sbomify.com/CVE-2025-70067/"}