# CVE-2025-7054: Infinite loop triggered by connection ID retirement

> An unauthenticated remote attacker can cause a denial of service in the quiche library by triggering an infinite loop during connection ID retirement.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2025
- **Updated:** 7 Aug 2025
- **Also known as:** GHSA-m3hh-f9gh-74c2

## What is CVE-2025-7054?

CVE-2025-7054 is a high-severity denial of service vulnerability in Cloudflare quiche, published on 7 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cloudflare quiche was discovered to be vulnerable to an infinite loop when sending packets containing RETIRE_CONNECTION_ID frames.

QUIC connections possess a set of connection identifiers (IDs); see  Section 5.1 of RFC 9000 https://datatracker.ietf.org/doc/html/rfc9000#section-5.1 . Once the QUIC handshake completes, a local endpoint is responsible for issuing and retiring Connection IDs that are used by the remote peer to populate the Destination Connection ID field in packets sent from remote to local. Each Connection ID has a sequence number to ensure synchronization between peers.

An unauthenticated remote attacker can exploit this vulnerability by first completing a handshake and then sending a specially-crafted set of frames that trigger a connection ID retirement in the victim. When the victim attempts to send a packet containing RETIRE_CONNECTION_ID frames,  Section 19.16 of RFC 9000 https://datatracker.ietf.org/doc/html/rfc9000#section-19.6  requires that the sequence number of the retired connection ID must not be the same as the sequence number of the connection ID used by the packet. In other words, a packet cannot contain a frame that retires itself. In scenarios such as path migration, it is possible for there to be multiple active paths with different active connection IDs that could be used to retire each other. The exploit triggered an unintentional behaviour of a quiche design feature that supports retirement across paths while maintaining full connection ID synchronization, leading to an infinite loop.This issue affects quiche: from 0.15.0 before 0.24.5.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2025-7054?

2 open source packages ship an affected version, including quiche. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `quiche` | crates.io | From 0.15.0 | 0.24.5 |
| `quiche` | crates.io | From 0.15.0 | 0.24.5 |

Products: Cloudflare Quiche.

## How do I fix CVE-2025-7054?

Upgrade quiche to 0.24.5 or later.

## Is CVE-2025-7054 being exploited?

There is no known exploitation of CVE-2025-7054 in the wild and no public exploit code.

## Other vulnerabilities in Cloudflare quiche

- [CVE-2026-12523](https://insights.sbomify.com/CVE-2026-12523/): Resource exhaustion in quiche HTTP/3 and QPACK layers (high 7.5)
- [CVE-2025-4821](https://insights.sbomify.com/CVE-2025-4821/): Incorrect congestion window growth by invalid ACK ranges (high 7.5)
- [CVE-2024-1765](https://insights.sbomify.com/CVE-2024-1765/): Unlimited resource allocation by QUIC CRYPTO frames flooding in quiche (medium 5.9)
- [CVE-2025-4820](https://insights.sbomify.com/CVE-2025-4820/): Incorrect congestion window growth by optimistic ACK (medium 5.3)
- [CVE-2023-6193](https://insights.sbomify.com/CVE-2023-6193/): Unbounded queuing of path validation messages in cloudflare-quiche (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-7054 and fix it if it is affected.

What it is: CVE-2025-7054 is a high-severity denial of service vulnerability in Cloudflare quiche, published on 7 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-7054 in the wild and no public exploit code.

Affected packages and fixed versions:
- quiche (crates.io): affected from 0.15.0; fixed in 0.24.5
- quiche (crates.io): affected from 0.15.0; fixed in 0.24.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-7054/ (Markdown: https://insights.sbomify.com/CVE-2025-7054/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-7054
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-7054
- OSV: https://osv.dev/vulnerability/CVE-2025-7054

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-7054/
Summaries are generated and may contain mistakes; the official description above is the record.
