CVE-2025-70792 Microweber Cross-site Scripting vulnerability

Medium 6.1 Published Updated

An attacker can execute arbitrary JavaScript in an admin's browser via a crafted URL, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-70792?

CVE-2025-70792 is a medium-severity cross-site scripting vulnerability in Microweber Microweber, published on 5 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Cross Site Scripting vulnerability in the "/admin/category/create" endpoint of Microweber 2.0.19. An attacker can manipulate the "rel_id" parameter in a crafted URL and lure a user with admin privileges into visiting it, achieving JavaScript code execution in the victim's browser. The issue was reported to the developers and fixed in version 2.0.20.

Weakness: CWE-79

Which versions are affected by CVE-2025-70792?

2 open source packages ship an affected version, including microweber/microweber. It affects 1 product.

PackageAffectedFixed in
microweber/microweber PackagistAll versions2.0.20
microweber/microweber PackagistAll versions2.0.20

Products include Microweber Microweber.

How do I fix CVE-2025-70792?

Upgrade microweber/microweber to 2.0.20 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-70792 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-70792 exists.

All Microweber Microweber vulnerabilities

Sources

Also known as GHSA-6w5w-jx4x-vjvw.

Is CVE-2025-70792 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free