# CVE-2025-70873: Information disclosure in n/a

> Attackers can read heap memory by supplying a crafted ZIP file to the SQLite zipfile extension, potentially exposing sensitive data.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2026
- **Updated:** 15 Oct 2026
- **Also known as:** AZL-83006, BIT-sqlite-2025-70873, DEBIAN-CVE-2025-70873, ECHO-186e-750f-440b, GHSA-p36r-6g67-869c, MGASA-2026-0195, MINI-3pj6-j6j8-r5xm, OESA-2026-1767, OESA-2026-1768, OESA-2026-1771, OESA-2026-1772, RHSA-2026:7656, ROOT-OS-ALPINE-318-CVE-2025-70873, ROOT-OS-ALPINE-319-CVE-2025-70873, ROOT-OS-ALPINE-320-CVE-2025-70873, ROOT-OS-ALPINE-321-CVE-2025-70873, ROOT-OS-ALPINE-322-CVE-2025-70873, openSUSE-SU-2026:10406-1

## What is CVE-2025-70873?

CVE-2025-70873 is a high-severity vulnerability in Sqlite Sqlite, published on 12 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An information disclosure issue in the zipfileInflate function in the zipfile extension in SQLite v3.51.1 and earlier allows attackers to obtain heap memory via supplying a crafted ZIP file.

Weakness: CWE-244 (Improper Clearing of Heap Memory Before Release)

## Which versions are affected by CVE-2025-70873?

1 open source package ship an affected version, including sqlite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sqlite` | Bitnami | All versions | 3.51.1 |
| `sqlite` | Red Hat:hummingbird:1 | All versions | 0:3.52.0-1.1.hum1 |
| `sqlite-analyzer` | Red Hat:hummingbird:1 | All versions | 0:3.52.0-1.1.hum1 |
| `sqlite-debug` | Red Hat:hummingbird:1 | All versions | 0:3.52.0-1.1.hum1 |
| `sqlite-devel` | Red Hat:hummingbird:1 | All versions | 0:3.52.0-1.1.hum1 |
| `sqlite-doc` | Red Hat:hummingbird:1 | All versions | 0:3.52.0-1.1.hum1 |
| `sqlite-libs` | Red Hat:hummingbird:1 | All versions | 0:3.52.0-1.1.hum1 |
| `sqlite-tcl` | Red Hat:hummingbird:1 | All versions | 0:3.52.0-1.1.hum1 |
| `sqlite-tools` | Red Hat:hummingbird:1 | All versions | 0:3.52.0-1.1.hum1 |
| `sqlite3` | openSUSE:Tumbleweed | All versions | 3.51.3-1.1 |

Products: Sqlite Sqlite.

## How do I fix CVE-2025-70873?

Upgrade sqlite to 3.51.1 or later.

## Is CVE-2025-70873 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-70873 exists.

## Other vulnerabilities in Sqlite Sqlite

- [CVE-2015-5895](https://insights.sbomify.com/CVE-2015-5895/): Other in n/a (critical 10.0)
- [CVE-2017-10989](https://insights.sbomify.com/CVE-2017-10989/): Memory corruption in n/a (critical 9.8)
- [CVE-2026-11822](https://insights.sbomify.com/CVE-2026-11822/): SQLite before 3.53.2 Memory Corruption in FTS5 Extension (high 8.5)
- [CVE-2026-11824](https://insights.sbomify.com/CVE-2026-11824/): SQLite before 3.53.2 Heap Buffer Overflow via FTS5 fts5ChunkIterate (high 8.5)
- [CVE-2021-31239](https://insights.sbomify.com/CVE-2021-31239/): Denial of service in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-70873 and fix it if it is affected.

What it is: CVE-2025-70873 is a high-severity vulnerability in Sqlite Sqlite, published on 12 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-70873 exists.

Affected packages and fixed versions:
- sqlite (Bitnami): affected all versions; fixed in 3.51.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-70873/ (Markdown: https://insights.sbomify.com/CVE-2025-70873/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-70873
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-70873
- OSV: https://osv.dev/vulnerability/CVE-2025-70873

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-70873/
Summaries are generated and may contain mistakes; the official description above is the record.
