{"answers":{"affected":"3 open source packages ship an affected version, including signify. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-70887 in the wild and no public exploit code.","fix":"Upgrade signify to 0.9.2 or later.","what":"CVE-2025-70887 is a high-severity vulnerability in n/a, published on 25 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-70887 and fix it if it is affected.\n\nWhat it is: CVE-2025-70887 is a high-severity vulnerability in n/a, published on 25 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-70887 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- signify (PyPI): affected all versions; fixed in 0.9.2\n- signify (PyPI): affected all versions; fixed in 0.9.2\n- signify (PyPI): affected all versions; fixed in 0.9.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-70887/ (Markdown: https://insights.sbomify.com/CVE-2025-70887/index.md)","id":"CVE-2025-70887","markdown":"https://insights.sbomify.com/CVE-2025-70887/index.md","name":"CVE-2025-70887","record":{"aliases":["GHSA-p4hh-mq57-gq8x","PYSEC-2026-2278"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Python Signify library","requires_auth":"low_privilege","summary":"A remote attacker can escalate privileges in the Signify Python library due to flaws in signed_data.py and context.py components.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"signify","vendor":"ralphje"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"An issue in ralphje Signify before v.0.9.2 allows a remote attacker to escalate privileges via the signed_data.py and the context.py components","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Signify allows a remote attacker to escalate privileges via the signed_data.py and the context.py components","id":"CVE-2025-70887","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"privilege_escalation","year":"2025"},"n_packages":3,"n_references":5,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2025-70888"},"packages":[{"ecosystem":"PyPI","fixed":["0.9.2"],"introduced":["0"],"last_affected":[],"package":"signify","purl":null,"source":"GHSA-p4hh-mq57-gq8x"},{"ecosystem":"PyPI","fixed":["0.9.2"],"introduced":["0"],"last_affected":[],"package":"signify","purl":"pkg:pypi/signify","source":"GHSA-p4hh-mq57-gq8x"},{"ecosystem":"PyPI","fixed":["0.9.2"],"introduced":["0"],"last_affected":[],"package":"signify","purl":"pkg:pypi/signify","source":"PYSEC-2026-2278"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2025-70886"},"products":["n/a"],"published":"2026-03-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-27","vendors":["n/a"]},"summary":"A remote attacker can escalate privileges in the Signify Python library due to flaws in signed_data.py and context.py components.","url":"https://insights.sbomify.com/CVE-2025-70887/"}