# CVE-2025-70887: Signify allows a remote attacker to escalate privileges via the signed_data.py and the context.py components

> A remote attacker can escalate privileges in the Signify Python library due to flaws in signed_data.py and context.py components.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2026
- **Updated:** 27 Mar 2026
- **Also known as:** GHSA-p4hh-mq57-gq8x, PYSEC-2026-2278

## What is CVE-2025-70887?

CVE-2025-70887 is a high-severity vulnerability in n/a, published on 25 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue in ralphje Signify before v.0.9.2 allows a remote attacker to escalate privileges via the signed_data.py and the context.py components

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2025-70887?

3 open source packages ship an affected version, including signify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `signify` | PyPI | All versions | 0.9.2 |
| `signify` | PyPI | All versions | 0.9.2 |
| `signify` | PyPI | All versions | 0.9.2 |

Products: Ralphje Signify.

## How do I fix CVE-2025-70887?

Upgrade signify to 0.9.2 or later.

## Is CVE-2025-70887 being exploited?

There is no known exploitation of CVE-2025-70887 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-70887 and fix it if it is affected.

What it is: CVE-2025-70887 is a high-severity vulnerability in n/a, published on 25 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-70887 in the wild and no public exploit code.

Affected packages and fixed versions:
- signify (PyPI): affected all versions; fixed in 0.9.2
- signify (PyPI): affected all versions; fixed in 0.9.2
- signify (PyPI): affected all versions; fixed in 0.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-70887/ (Markdown: https://insights.sbomify.com/CVE-2025-70887/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-70887
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-70887
- OSV: https://osv.dev/vulnerability/CVE-2025-70887

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-70887/
Summaries are generated and may contain mistakes; the official description above is the record.
