{"answers":{"affected":"2 open source packages ship an affected version, including com.alibaba:fastjson.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-70974 exists.","fix":"Upgrade com.alibaba:fastjson to 1.2.48 or later.","what":"CVE-2025-70974 is a critical unsafe deserialization vulnerability in Alibaba Fastjson, published on 9 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-70974 and fix it if it is affected.\n\nWhat it is: CVE-2025-70974 is a critical unsafe deserialization vulnerability in Alibaba Fastjson, published on 9 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-70974 exists.\n\nAffected packages and fixed versions:\n- com.alibaba:fastjson (Maven): affected all versions; fixed in 1.2.48\n- com.alibaba:fastjson (Maven): affected all versions; fixed in 1.2.48\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-70974/ (Markdown: https://insights.sbomify.com/CVE-2025-70974/index.md)","id":"CVE-2025-70974","markdown":"https://insights.sbomify.com/CVE-2025-70974/index.md","name":"CVE-2025-70974","record":{"aliases":["GHSA-jm7w-5684-pvh8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java JSON library","requires_auth":"none","summary":"Attackers can achieve remote code execution via JNDI injection by exploiting unsafe autoType handling in the Fastjson library.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"}],"description":"Fastjson before 1.2.48 mishandles autoType because, when an @type key is in a JSON document, and the value of that key is the name of a Java class, there may be calls to certain public methods of that class. Depending on the behavior of those methods, there may be JNDI injection with an attacker-supplied payload located elsewhere in that JSON document. This was exploited in the wild in 2023 through 2025. NOTE: this issue exists because of an incomplete fix for CVE-2017-18349. Also, a later bypass is covered by CVE-2022-25845.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"FASTJSON Includes Functionality from Untrusted Control Sphere","id":"CVE-2025-70974","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":2,"n_references":7,"next":{"headline":"SQL injection in n/a","id":"CVE-2025-70981"},"packages":[{"ecosystem":"Maven","fixed":["1.2.48"],"introduced":["0"],"last_affected":[],"package":"com.alibaba:fastjson","purl":null,"source":"GHSA-jm7w-5684-pvh8"},{"ecosystem":"Maven","fixed":["1.2.48"],"introduced":["0"],"last_affected":[],"package":"com.alibaba:fastjson","purl":"pkg:maven/com.alibaba/fastjson","source":"GHSA-jm7w-5684-pvh8"}],"prev":{"headline":"Auth bypass in n/a","id":"CVE-2025-70973"},"products":["Fastjson"],"published":"2026-01-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["Alibaba"]},"summary":"Attackers can achieve remote code execution via JNDI injection by exploiting unsafe autoType handling in the Fastjson library.","url":"https://insights.sbomify.com/CVE-2025-70974/"}