# CVE-2025-70974: FASTJSON Includes Functionality from Untrusted Control Sphere

> Attackers can achieve remote code execution via JNDI injection by exploiting unsafe autoType handling in the Fastjson library.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jan 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-jm7w-5684-pvh8

## What is CVE-2025-70974?

CVE-2025-70974 is a critical unsafe deserialization vulnerability in Alibaba Fastjson, published on 9 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fastjson before 1.2.48 mishandles autoType because, when an @type key is in a JSON document, and the value of that key is the name of a Java class, there may be calls to certain public methods of that class. Depending on the behavior of those methods, there may be JNDI injection with an attacker-supplied payload located elsewhere in that JSON document. This was exploited in the wild in 2023 through 2025. NOTE: this issue exists because of an incomplete fix for CVE-2017-18349. Also, a later bypass is covered by CVE-2022-25845.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2025-70974?

2 open source packages ship an affected version, including com.alibaba:fastjson.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.alibaba:fastjson` | Maven | All versions | 1.2.48 |
| `com.alibaba:fastjson` | Maven | All versions | 1.2.48 |

## How do I fix CVE-2025-70974?

Upgrade com.alibaba:fastjson to 1.2.48 or later.

## Is CVE-2025-70974 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-70974 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-70974 and fix it if it is affected.

What it is: CVE-2025-70974 is a critical unsafe deserialization vulnerability in Alibaba Fastjson, published on 9 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-70974 exists.

Affected packages and fixed versions:
- com.alibaba:fastjson (Maven): affected all versions; fixed in 1.2.48
- com.alibaba:fastjson (Maven): affected all versions; fixed in 1.2.48

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-70974/ (Markdown: https://insights.sbomify.com/CVE-2025-70974/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-70974
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-70974
- OSV: https://osv.dev/vulnerability/CVE-2025-70974

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-70974/
Summaries are generated and may contain mistakes; the official description above is the record.
