# CVE-2025-71320: picklescan - Remote Code Execution via Incomplete Disallowed Inputs

> Remote attackers can achieve arbitrary code execution by crafting malicious pickle files that bypass picklescan's incomplete deny-list.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2026
- **Updated:** 17 Jun 2026
- **Also known as:** GHSA-84r2-jw7c-4r5q, PYSEC-2026-1785

## What is CVE-2025-71320?

CVE-2025-71320 is a critical unsafe deserialization vulnerability in picklescan, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

picklescan before 0.0.33 contains an incomplete deny-list that fails to block pydoc.locate and operator.methodcaller functions, allowing attackers to bypass security checks. Remote attackers can craft malicious pickle files using these unblocked functions to achieve arbitrary code execution when the pickle is deserialized.

Weakness: CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2025-71320?

3 open source packages ship an affected version, including picklescan.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `picklescan` | PyPI | All versions | 0.0.33 |
| `picklescan` | PyPI | All versions | 0.0.33 |
| `picklescan` | PyPI | All versions | 0.0.33 |

## How do I fix CVE-2025-71320?

Upgrade picklescan to 0.0.33 or later.

## Is CVE-2025-71320 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71320 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71320 and fix it if it is affected.

What it is: CVE-2025-71320 is a critical unsafe deserialization vulnerability in picklescan, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71320 exists.

Affected packages and fixed versions:
- picklescan (PyPI): affected all versions; fixed in 0.0.33
- picklescan (PyPI): affected all versions; fixed in 0.0.33
- picklescan (PyPI): affected all versions; fixed in 0.0.33

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71320/ (Markdown: https://insights.sbomify.com/CVE-2025-71320/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71320
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71320
- OSV: https://osv.dev/vulnerability/CVE-2025-71320

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71320/
Summaries are generated and may contain mistakes; the official description above is the record.
