# CVE-2025-71322: PickleScan - Unsafe Globals Check Bypass via pty.spawn Function

> Attackers can bypass PickleScan's security checks using pty.spawn to achieve arbitrary code execution when processing malicious pickle files.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Jun 2026
- **Updated:** 18 Jun 2026
- **Also known as:** GHSA-hgrh-qx5j-jfwx, PYSEC-2026-1790

## What is CVE-2025-71322?

CVE-2025-71322 is a high-severity vulnerability in PickleScan, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

PickleScan before 0.0.33 fails to include the pty.spawn function in its unsafe globals list, allowing attackers to bypass security checks. Malicious actors can craft pickle payloads using pty.spawn to achieve arbitrary code execution when files are processed by PickleScan.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2025-71322?

3 open source packages ship an affected version, including picklescan.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `picklescan` | PyPI | All versions | 0.0.33 |
| `picklescan` | PyPI | All versions | 0.0.33 |
| `picklescan` | PyPI | All versions | 0.0.33 |

## How do I fix CVE-2025-71322?

Upgrade picklescan to 0.0.33 or later.

## Is CVE-2025-71322 being exploited?

There is no known exploitation of CVE-2025-71322 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71322 and fix it if it is affected.

What it is: CVE-2025-71322 is a high-severity vulnerability in PickleScan, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-71322 in the wild and no public exploit code.

Affected packages and fixed versions:
- picklescan (PyPI): affected all versions; fixed in 0.0.33
- picklescan (PyPI): affected all versions; fixed in 0.0.33
- picklescan (PyPI): affected all versions; fixed in 0.0.33

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71322/ (Markdown: https://insights.sbomify.com/CVE-2025-71322/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71322
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71322
- OSV: https://osv.dev/vulnerability/CVE-2025-71322

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71322/
Summaries are generated and may contain mistakes; the official description above is the record.
