# CVE-2025-71324: Flowise - Arbitrary File Read via chatId Parameter

> Unauthenticated attackers can read sensitive files via path traversal in the chatId parameter, exposing database content in Flowise.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Jun 2026
- **Updated:** 30 Jun 2026
- **Also known as:** GHSA-4pwq-xw7j-m297, GHSA-99pg-hqvx-r4gf

## What is CVE-2025-71324?

CVE-2025-71324 is a high-severity path traversal vulnerability in Flowiseai Flowise, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Flowise before 3.0.6 contains an arbitrary file read vulnerability in the chatId parameter of the /api/v1/get-upload-file and /api/v1/openai-assistants-file/download endpoints. The chatId value is not validated and is passed to streamStorageFile(), where a fallback file-lookup path constructed without the orgId is evaluated after the storage-directory containment check, allowing path traversal beyond the intended storage directory. Unauthenticated attackers can read sensitive files such as /root/.flowise/database.sqlite, exposing all database content in the default configuration.

Weakness: CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2025-71324?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | From 3.0.5 | 3.0.6 |
| `flowise` | npm | From 3.0.5 | 3.0.6 |

Products: Flowiseai Flowise.

## How do I fix CVE-2025-71324?

Upgrade flowise to 3.0.6 or later.

## Is CVE-2025-71324 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71324 exists.

Public exploit code:

- Flowise - Path Traversal (nuclei): http/cves/2025/CVE-2025-71324.yaml

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71324 and fix it if it is affected.

What it is: CVE-2025-71324 is a high-severity path traversal vulnerability in Flowiseai Flowise, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71324 exists.

Affected packages and fixed versions:
- flowise (npm): affected from 3.0.5; fixed in 3.0.6
- flowise (npm): affected from 3.0.5; fixed in 3.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71324/ (Markdown: https://insights.sbomify.com/CVE-2025-71324/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71324
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71324
- OSV: https://osv.dev/vulnerability/CVE-2025-71324

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71324/
Summaries are generated and may contain mistakes; the official description above is the record.
