{"answers":{"affected":"2 open source packages ship an affected version, including flowise-ui. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71328 exists.","fix":"Upgrade flowise-ui to 3.0.10 or later.","what":"CVE-2025-71328 is a high-severity authentication bypass vulnerability in Flowiseai Flowise, published on 25 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-71328 and fix it if it is affected.\n\nWhat it is: CVE-2025-71328 is a high-severity authentication bypass vulnerability in Flowiseai Flowise, published on 25 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71328 exists.\n\nAffected packages and fixed versions:\n- flowise-ui (npm): affected all versions; fixed in 3.0.10\n- flowise-ui (npm): affected all versions; fixed in 3.0.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-71328/ (Markdown: https://insights.sbomify.com/CVE-2025-71328/index.md)","id":"CVE-2025-71328","markdown":"https://insights.sbomify.com/CVE-2025-71328/index.md","name":"CVE-2025-71328","record":{"aliases":["GHSA-f44q-84cr-v374","GHSA-fjh6-8679-9pch"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Flowise AI platform","requires_auth":"low_privilege","summary":"Authenticated users can change passwords without verification, enabling account takeover if sessions are hijacked.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"flowise","vendor":"flowiseai"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-620","name":"Unverified Password Change"}],"description":"Flowise before 3.0.10 contains an unverified password change vulnerability. An authenticated user can change their account password through the account settings (Security) section without supplying the current password or any additional verification, as the application does not enforce a current-password check on the credential change. This can lead to full account takeover, particularly if an attacker can hijack or coerce an authenticated session.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Flowise - Unverified Password Change via Account Settings","id":"CVE-2025-71328","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"flowiseai:flowise","products":["flowiseai:flowise"],"type":"auth_bypass","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"image-size 2.0.2 Denial of Service via Infinite Loop in JXL/HEIF Parser","id":"CVE-2025-71329"},"packages":[{"ecosystem":"npm","fixed":["3.0.10"],"introduced":["0"],"last_affected":[],"package":"flowise-ui","purl":null,"source":"GHSA-fjh6-8679-9pch"},{"ecosystem":"npm","fixed":["3.0.10"],"introduced":["0"],"last_affected":[],"package":"flowise-ui","purl":"pkg:npm/flowise-ui","source":"GHSA-fjh6-8679-9pch"}],"prev":{"headline":"Flowise - Authentication Bypass via Unprotected Registration Endpoint","id":"CVE-2025-71327"},"products":["Flowise"],"published":"2026-06-25","related":[{"cvss_score":10,"headline":"Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API","id":"CVE-2025-71338","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":10,"headline":"Flowise: Authenticated RCE Via MCP Adapters","id":"CVE-2026-40933","kev_date_added":null,"published":"2026-04-21"},{"cvss_score":10,"headline":"Flowise is vulnerable to arbitrary file read, arbitrary file write","id":"CVE-2025-61913","kev_date_added":null,"published":"2025-10-08"},{"cvss_score":10,"headline":"Flowise has Remote Code Execution vulnerability","id":"CVE-2025-59528","kev_date_added":null,"published":"2025-09-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2026-52098","kev_date_added":null,"published":"2026-09-10"},{"cvss_score":9.8,"headline":"Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover","id":"CVE-2025-58434","kev_date_added":null,"published":"2025-09-12"},{"cvss_score":9.8,"headline":"Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers","id":"CVE-2025-8943","kev_date_added":null,"published":"2025-08-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-26","vendors":["Flowise"]},"summary":"Authenticated users can change passwords without verification, enabling account takeover if sessions are hijacked.","url":"https://insights.sbomify.com/CVE-2025-71328/"}