# CVE-2025-71329: image-size 2.0.2 Denial of Service via Infinite Loop in JXL/HEIF Parser

> Remote attackers can cause a permanent application hang in image-size by supplying crafted JXL or HEIF images with zero-sized boxes, blocking the Node.js event loop.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-5p2g-fcmc-qvqq, MINI-8pqf-2pj3-275w, MINI-fqhj-qvmc-8f88, MINI-vpcc-p3h3-xv54, ROOT-APP-NPM-CVE-2025-71329

## What is CVE-2025-71329?

CVE-2025-71329 is a high-severity denial of service vulnerability in image-size, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

image-size through 2.0.2 contains a denial of service vulnerability that allows remote attackers to permanently block the Node.js event loop by supplying a specially crafted image buffer with a zero-valued size field in a recognized box-type. Attackers can trigger an infinite loop in the JXL or HEIF image parsers by providing a crafted image containing a box with a size of zero, causing the offset to never advance and permanently hanging the application.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2025-71329?

2 open source packages ship an affected version, including image-size. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `image-size` | npm | From 1.2.0 | 2.0.3 |
| `image-size` | npm | From 1.2.0 | 2.0.3 |

Products: Image-Size Image-Size.

## How do I fix CVE-2025-71329?

Upgrade image-size to 2.0.3 or later.

## Is CVE-2025-71329 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71329 exists.

Public exploit code:

- Community-maintained fork of image-size with fixes for CVE-2025-71329 and CVE-2025-71330 (github_poc): https://github.com/lcf2212dev/image-size-next

## Other vulnerabilities in image-size

- [CVE-2025-71330](https://insights.sbomify.com/CVE-2025-71330/): image-size 2.0.2 Denial of Service via Malformed ICNS Image Parsing (high 8.7)
- [CVE-2025-71319](https://insights.sbomify.com/CVE-2025-71319/): image-size 2.0.2 Denial of Service via Infinite Loop in JXL/HEIF Parser (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71329 and fix it if it is affected.

What it is: CVE-2025-71329 is a high-severity denial of service vulnerability in image-size, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71329 exists.

Affected packages and fixed versions:
- image-size (npm): affected from 1.2.0; fixed in 2.0.3
- image-size (npm): affected from 1.2.0; fixed in 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71329/ (Markdown: https://insights.sbomify.com/CVE-2025-71329/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71329
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71329
- OSV: https://osv.dev/vulnerability/CVE-2025-71329

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71329/
Summaries are generated and may contain mistakes; the official description above is the record.
