{"answers":{"affected":"2 open source packages ship an affected version, including image-size. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71330 exists.","fix":"Upgrade image-size to 2.0.3 or later.","what":"CVE-2025-71330 is a high-severity denial of service vulnerability in image-size, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-71330 and fix it if it is affected.\n\nWhat it is: CVE-2025-71330 is a high-severity denial of service vulnerability in image-size, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71330 exists.\n\nAffected packages and fixed versions:\n- image-size (npm): affected from 0.6.3; fixed in 2.0.3\n- image-size (npm): affected from 0.6.3; fixed in 2.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-71330/ (Markdown: https://insights.sbomify.com/CVE-2025-71330/index.md)","id":"CVE-2025-71330","markdown":"https://insights.sbomify.com/CVE-2025-71330/index.md","name":"CVE-2025-71330","record":{"aliases":["CLSA-2026-1792743661","CLSA-2026-1792743831","GHSA-w3rx-r6r6-pgpr","MINI-5g27-998v-3p2x","MINI-9f27-q9qf-77cm","MINI-gxg7-q37f-6xf5","ROOT-APP-NPM-CVE-2025-71330"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js image library","requires_auth":"none","summary":"Remote attackers can cause a permanent denial of service in Node.js applications by supplying a malformed ICNS image that triggers an infinite loop.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"image-size","vendor":"image-size"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"}],"description":"image-size through 2.0.2 contains a denial of service vulnerability that allows remote attackers to permanently block the Node.js event loop by supplying a specially crafted ICNS image buffer. Attackers can craft an ICNS buffer containing valid magic bytes and a zero-valued entry length field to trigger an infinite loop in the ICNS parser, as the offset is never incremented when the entry length field is 0, causing the while loop condition to remain true indefinitely.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"image-size 2.0.2 Denial of Service via Malformed ICNS Image Parsing","id":"CVE-2025-71330","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Flowise - Cross-Site Scripting in Chat Messages and Agent Workflows","id":"CVE-2025-71331"},"packages":[{"ecosystem":"npm","fixed":["2.0.3"],"introduced":["0.6.3"],"last_affected":[],"package":"image-size","purl":null,"source":"GHSA-w3rx-r6r6-pgpr"},{"ecosystem":"npm","fixed":["2.0.3"],"introduced":["0.6.3"],"last_affected":[],"package":"image-size","purl":"pkg:npm/image-size","source":"GHSA-w3rx-r6r6-pgpr"}],"prev":{"headline":"image-size 2.0.2 Denial of Service via Infinite Loop in JXL/HEIF Parser","id":"CVE-2025-71329"},"products":["image-size"],"published":"2026-06-10","related":[{"cvss_score":8.7,"headline":"image-size 2.0.2 Denial of Service via Infinite Loop in JXL/HEIF Parser","id":"CVE-2025-71329","kev_date_added":null,"published":"2026-06-10"},{"cvss_score":8.7,"headline":"image-size 2.0.2 Denial of Service via Infinite Loop in JXL/HEIF Parser","id":"CVE-2025-71319","kev_date_added":null,"published":"2026-06-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-14","vendors":["image-size"]},"summary":"Remote attackers can cause a permanent denial of service in Node.js applications by supplying a malformed ICNS image that triggers an infinite loop.","url":"https://insights.sbomify.com/CVE-2025-71330/"}