{"answers":{"affected":"2 open source packages ship an affected version, including flowise. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71331 exists.","fix":"Upgrade flowise to 3.0.8 or later.","what":"CVE-2025-71331 is a medium-severity cross-site scripting vulnerability in Flowiseai Flowise, published on 20 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-71331 and fix it if it is affected.\n\nWhat it is: CVE-2025-71331 is a medium-severity cross-site scripting vulnerability in Flowiseai Flowise, published on 20 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71331 exists.\n\nAffected packages and fixed versions:\n- flowise (npm): affected all versions; fixed in 3.0.8\n- flowise (npm): affected all versions; fixed in 3.0.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-71331/ (Markdown: https://insights.sbomify.com/CVE-2025-71331/index.md)","id":"CVE-2025-71331","markdown":"https://insights.sbomify.com/CVE-2025-71331/index.md","name":"CVE-2025-71331","record":{"aliases":["GHSA-4fr9-3x69-36wv","GHSA-jv86-v5fr-xvg6"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Flowise AI platform","requires_auth":"none","summary":"Attackers can inject malicious JavaScript into Flowise chat messages or agent workflows to steal cookies and session data from victims.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"flowise","vendor":"flowiseai"}],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"}],"description":"Flowise before 3.0.8 contains a cross-site scripting (XSS) vulnerability caused by insufficient input filtering in chat messages and custom agent functions. An attacker can inject malicious JavaScript by sending an iframe payload (e.g., \u003ciframe src=\"javascript:alert(document.cookie)\"\u003e) in a chat box, or by having a custom agent function return an XSS payload from an external website. The injected script executes in the victim's browser, enabling theft of cookies and session data.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Flowise - Cross-Site Scripting in Chat Messages and Agent Workflows","id":"CVE-2025-71331","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"flowiseai:flowise","products":["flowiseai:flowise"],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Flowise - SQL Injection in importChatflows API via chatflow.id Parameter","id":"CVE-2025-71332"},"packages":[{"ecosystem":"npm","fixed":["3.0.8"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":null,"source":"GHSA-4fr9-3x69-36wv"},{"ecosystem":"npm","fixed":["3.0.8"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":"pkg:npm/flowise","source":"GHSA-4fr9-3x69-36wv"}],"prev":{"headline":"image-size 2.0.2 Denial of Service via Malformed ICNS Image Parsing","id":"CVE-2025-71330"},"products":["Flowise"],"published":"2026-06-20","related":[{"cvss_score":10,"headline":"Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API","id":"CVE-2025-71338","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":10,"headline":"Flowise: Authenticated RCE Via MCP Adapters","id":"CVE-2026-40933","kev_date_added":null,"published":"2026-04-21"},{"cvss_score":10,"headline":"Flowise is vulnerable to arbitrary file read, arbitrary file write","id":"CVE-2025-61913","kev_date_added":null,"published":"2025-10-08"},{"cvss_score":10,"headline":"Flowise has Remote Code Execution vulnerability","id":"CVE-2025-59528","kev_date_added":null,"published":"2025-09-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2026-52098","kev_date_added":null,"published":"2026-09-10"},{"cvss_score":9.8,"headline":"Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover","id":"CVE-2025-58434","kev_date_added":null,"published":"2025-09-12"},{"cvss_score":9.8,"headline":"Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers","id":"CVE-2025-8943","kev_date_added":null,"published":"2025-08-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-22","vendors":["Flowise"]},"summary":"Attackers can inject malicious JavaScript into Flowise chat messages or agent workflows to steal cookies and session data from victims.","url":"https://insights.sbomify.com/CVE-2025-71331/"}