# CVE-2025-71331: Flowise - Cross-Site Scripting in Chat Messages and Agent Workflows

> Attackers can inject malicious JavaScript into Flowise chat messages or agent workflows to steal cookies and session data from victims.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 20 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** GHSA-4fr9-3x69-36wv, GHSA-jv86-v5fr-xvg6

## What is CVE-2025-71331?

CVE-2025-71331 is a medium-severity cross-site scripting vulnerability in Flowiseai Flowise, published on 20 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Flowise before 3.0.8 contains a cross-site scripting (XSS) vulnerability caused by insufficient input filtering in chat messages and custom agent functions. An attacker can inject malicious JavaScript by sending an iframe payload (e.g., <iframe src="javascript:alert(document.cookie)">) in a chat box, or by having a custom agent function return an XSS payload from an external website. The injected script executes in the victim's browser, enabling theft of cookies and session data.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2025-71331?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 3.0.8 |
| `flowise` | npm | All versions | 3.0.8 |

Products: Flowiseai Flowise.

## How do I fix CVE-2025-71331?

Upgrade flowise to 3.0.8 or later.

## Is CVE-2025-71331 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71331 exists.

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71331 and fix it if it is affected.

What it is: CVE-2025-71331 is a medium-severity cross-site scripting vulnerability in Flowiseai Flowise, published on 20 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71331 exists.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.0.8
- flowise (npm): affected all versions; fixed in 3.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71331/ (Markdown: https://insights.sbomify.com/CVE-2025-71331/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71331
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71331
- OSV: https://osv.dev/vulnerability/CVE-2025-71331

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71331/
Summaries are generated and may contain mistakes; the official description above is the record.
