CVE-2025-71335 Flowise - Session Invalidation Failure After Password Change
Attackers with active sessions retain access after password changes, bypassing session invalidation controls in Flowise.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-71335?
CVE-2025-71335 is a high-severity vulnerability in Flowiseai Flowise, published on 25 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Flowise before 3.0.10 (affected versions 3.0.7 and earlier) fails to invalidate existing sessions and session tokens after a user changes their password. An attacker who already holds an active session, for example via a stolen session token or a device left logged in, remains authenticated as the legitimate user even after the user rotates their credentials, undermining the security purpose of the password change.
Weakness: CWE-613
Which versions are affected by CVE-2025-71335?
2 open source packages ship an affected version, including flowise. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
flowise npm | All versions | 3.0.10 |
flowise npm | All versions | 3.0.10 |
Products include Flowiseai Flowise.
How do I fix CVE-2025-71335?
Upgrade flowise to 3.0.10 or later.
Is CVE-2025-71335 being exploited?
There is no known exploitation of CVE-2025-71335 in the wild and no public exploit code.
Other vulnerabilities in Flowiseai Flowise
- CVE-2025-71338 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API
- CVE-2026-40933 Flowise: Authenticated RCE Via MCP Adapters
- CVE-2025-61913 Flowise is vulnerable to arbitrary file read, arbitrary file write
- CVE-2025-59528 Flowise has Remote Code Execution vulnerability
- CVE-2026-52098 Code injection in n/a
Sources
Also known as GHSA-289x-5mj7-xhg5, GHSA-x7rp-qj2h-ghgw.