# CVE-2025-71335: Flowise - Session Invalidation Failure After Password Change

> Attackers with active sessions retain access after password changes, bypassing session invalidation controls in Flowise.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Jun 2026
- **Updated:** 26 Jun 2026
- **Also known as:** GHSA-289x-5mj7-xhg5, GHSA-x7rp-qj2h-ghgw

## What is CVE-2025-71335?

CVE-2025-71335 is a high-severity vulnerability in Flowiseai Flowise, published on 25 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flowise before 3.0.10 (affected versions 3.0.7 and earlier) fails to invalidate existing sessions and session tokens after a user changes their password. An attacker who already holds an active session, for example via a stolen session token or a device left logged in, remains authenticated as the legitimate user even after the user rotates their credentials, undermining the security purpose of the password change.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2025-71335?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 3.0.10 |
| `flowise` | npm | All versions | 3.0.10 |

Products: Flowiseai Flowise.

## How do I fix CVE-2025-71335?

Upgrade flowise to 3.0.10 or later.

## Is CVE-2025-71335 being exploited?

There is no known exploitation of CVE-2025-71335 in the wild and no public exploit code.

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71335 and fix it if it is affected.

What it is: CVE-2025-71335 is a high-severity vulnerability in Flowiseai Flowise, published on 25 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-71335 in the wild and no public exploit code.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.0.10
- flowise (npm): affected all versions; fixed in 3.0.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71335/ (Markdown: https://insights.sbomify.com/CVE-2025-71335/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71335
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71335
- OSV: https://osv.dev/vulnerability/CVE-2025-71335

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71335/
Summaries are generated and may contain mistakes; the official description above is the record.
