# CVE-2025-71336: Flowise - Unsandboxed Remote Code Execution via Custom MCP

> Attackers can execute arbitrary OS commands via the Custom MCP feature due to missing authentication and input validation, leading to full system compromise.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Jun 2026
- **Updated:** 30 Jun 2026
- **Also known as:** GHSA-6933-jpx5-q87q, GHSA-q2xp-j85q-883h

## What is CVE-2025-71336?

CVE-2025-71336 is a critical command injection vulnerability in Flowiseai Flowise, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Flowise before 3.0.6 (affected versions 2.2.7-patch.1 and earlier) contains an unsandboxed remote code execution vulnerability in the Custom MCP feature, which is designed to execute OS commands such as launching local MCP servers. Because Flowise's authentication and authorization model is minimal and lacks role-based access control, and the default installation runs without authentication unless FLOWISE_USERNAME and FLOWISE_PASSWORD are set, an attacker can send a crafted JSON payload with the header 'x-request-from: internal' to the /api/v1/node-load-method/customMCP endpoint to execute arbitrary OS commands, resulting in complete compromise of the platform container or server.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-71336?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | From 2.2.7-patch.1 | 3.0.6 |
| `flowise` | npm | From 2.2.7-patch.1 | 3.0.6 |

Products: Flowiseai Flowise.

## How do I fix CVE-2025-71336?

Upgrade flowise to 3.0.6 or later.

## Is CVE-2025-71336 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71336 exists.

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71336 and fix it if it is affected.

What it is: CVE-2025-71336 is a critical command injection vulnerability in Flowiseai Flowise, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71336 exists.

Affected packages and fixed versions:
- flowise (npm): affected from 2.2.7-patch.1; fixed in 3.0.6
- flowise (npm): affected from 2.2.7-patch.1; fixed in 3.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71336/ (Markdown: https://insights.sbomify.com/CVE-2025-71336/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71336
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71336
- OSV: https://osv.dev/vulnerability/CVE-2025-71336

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71336/
Summaries are generated and may contain mistakes; the official description above is the record.
