# CVE-2025-71338: Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API

> Unauthenticated attackers can exploit path traversal in the document-store API to write arbitrary files, leading to remote code execution.

- **Severity:** Critical 10.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Jun 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-8vvx-qvq9-5948, GHSA-c3hj-m5hq-59xw

## What is CVE-2025-71338?

CVE-2025-71338 is a critical path traversal vulnerability in Flowiseai Flowise, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Flowise through 2.2.7 fails to sanitize path segments in the document-store loader endpoint, allowing unauthenticated attackers to write files outside the storage directory. Attackers can use parent-directory sequences to escape the storage directory and overwrite application files loaded at boot for remote code execution.

Weakness: CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2025-71338?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions to 2.2.7 | None |
| `flowise` | npm | All versions to 2.2.7 | None |

Products: Flowiseai Flowise.

## How do I fix CVE-2025-71338?

No fix has been published for CVE-2025-71338 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-71338 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71338 exists.

Public exploit code:

- Unauthenticated arbitrary file read in Flowise (< 2.2.4) via path traversal in getFileFromStorage (storageUtils.ts). Caused by un-sanitized file path combined with mass-assignment in PUT /api/v1/document-store/store/:id. Allows full compromise via /root/.flowise/encryption.key read. Distinct from CVE-2025-71338 (fixed in 2.2.4). (github_poc): https://github.com/majpuV/flowise-arbitrary-file-read-getFileFromStorage

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)
- [CVE-2025-58434](https://insights.sbomify.com/CVE-2025-58434/): Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71338 and fix it if it is affected.

What it is: CVE-2025-71338 is a critical path traversal vulnerability in Flowiseai Flowise, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71338 exists.

Affected packages and fixed versions:
- flowise (npm): affected all versions up to 2.2.7; no fix listed
- flowise (npm): affected all versions up to 2.2.7; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71338/ (Markdown: https://insights.sbomify.com/CVE-2025-71338/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71338
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71338
- OSV: https://osv.dev/vulnerability/CVE-2025-71338

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71338/
Summaries are generated and may contain mistakes; the official description above is the record.
