# CVE-2025-71354: picklescan - Remote Code Execution via idlelib.debugobj.ObjectTreeItem.SetText

> Attackers can bypass picklescan detection to execute arbitrary code via malicious pickle files exploiting idlelib internals.

- **Severity:** High 7.6 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-3vg9-h568-4w9m, PYSEC-2026-1781

## What is CVE-2025-71354?

CVE-2025-71354 is a high-severity unsafe deserialization vulnerability in picklescan, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

picklescan before 0.0.29 fails to detect malicious pickle files that exploit idlelib.debugobj.ObjectTreeItem.SetText function in reduce methods. Attackers can craft pickle files with embedded code that bypasses picklescan detection and executes arbitrary commands when pickle.load() is called.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-71354?

3 open source packages ship an affected version, including picklescan.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `picklescan` | PyPI | All versions | 0.0.29 |
| `picklescan` | PyPI | All versions | 0.0.29 |
| `picklescan` | PyPI | All versions | 0.0.29 |

## How do I fix CVE-2025-71354?

Upgrade picklescan to 0.0.29 or later.

## Is CVE-2025-71354 being exploited?

There is no known exploitation of CVE-2025-71354 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71354 and fix it if it is affected.

What it is: CVE-2025-71354 is a high-severity unsafe deserialization vulnerability in picklescan, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-71354 in the wild and no public exploit code.

Affected packages and fixed versions:
- picklescan (PyPI): affected all versions; fixed in 0.0.29
- picklescan (PyPI): affected all versions; fixed in 0.0.29
- picklescan (PyPI): affected all versions; fixed in 0.0.29

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71354/ (Markdown: https://insights.sbomify.com/CVE-2025-71354/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71354
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71354
- OSV: https://osv.dev/vulnerability/CVE-2025-71354

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71354/
Summaries are generated and may contain mistakes; the official description above is the record.
