# CVE-2025-71361: picklescan - Remote Code Execution via Undetected idlelib.calltip.Calltip.fetch_tip

> Attackers can execute arbitrary code by crafting pickle files that bypass picklescan's detection of malicious idlelib calls.

- **Severity:** High 7.6 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-8r4j-24qv-fmq9, PYSEC-2026-1786

## What is CVE-2025-71361?

CVE-2025-71361 is a high-severity unsafe deserialization vulnerability in picklescan, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

picklescan before 0.0.29 fails to detect malicious idlelib.calltip.Calltip.fetch_tip calls in pickle files, allowing remote code execution. Attackers can embed undetected payloads in pickle files that execute arbitrary code when loaded via pickle.load().

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2025-71361?

3 open source packages ship an affected version, including picklescan.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `picklescan` | PyPI | All versions | 0.0.29 |
| `picklescan` | PyPI | All versions | 0.0.29 |
| `picklescan` | PyPI | All versions | 0.0.29 |

## How do I fix CVE-2025-71361?

Upgrade picklescan to 0.0.29 or later.

## Is CVE-2025-71361 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71361 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71361 and fix it if it is affected.

What it is: CVE-2025-71361 is a high-severity unsafe deserialization vulnerability in picklescan, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71361 exists.

Affected packages and fixed versions:
- picklescan (PyPI): affected all versions; fixed in 0.0.29
- picklescan (PyPI): affected all versions; fixed in 0.0.29
- picklescan (PyPI): affected all versions; fixed in 0.0.29

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71361/ (Markdown: https://insights.sbomify.com/CVE-2025-71361/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71361
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71361
- OSV: https://osv.dev/vulnerability/CVE-2025-71361

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71361/
Summaries are generated and may contain mistakes; the official description above is the record.
