{"answers":{"affected":"3 open source packages ship an affected version, including picklescan.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71370 exists.","fix":"Upgrade picklescan to 0.0.28 or later.","what":"CVE-2025-71370 is a high-severity unsafe deserialization vulnerability in picklescan, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-71370 and fix it if it is affected.\n\nWhat it is: CVE-2025-71370 is a high-severity unsafe deserialization vulnerability in picklescan, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71370 exists.\n\nAffected packages and fixed versions:\n- picklescan (PyPI): affected all versions; fixed in 0.0.28\n- picklescan (PyPI): affected all versions; fixed in 0.0.28\n- picklescan (PyPI): affected all versions; fixed in 0.0.28\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-71370/ (Markdown: https://insights.sbomify.com/CVE-2025-71370/index.md)","id":"CVE-2025-71370","markdown":"https://insights.sbomify.com/CVE-2025-71370/index.md","name":"CVE-2025-71370","record":{"aliases":["GHSA-vr7h-p6mm-wpmh","PYSEC-2026-4136"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python security library","requires_auth":"none","summary":"Attackers can bypass picklescan detection to execute arbitrary code via malicious pickle files containing unsupported tensor operations.","user_interaction":"required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"picklescan before 0.0.28 fails to detect malicious torch.jit.unsupported_tensor_ops.execWrapper function calls embedded in pickle files. Attackers can craft malicious pickle files that bypass picklescan detection and execute arbitrary code when loaded via pickle.load().","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"picklescan - Remote Code Execution via torch.jit.unsupported_tensor_ops.execWrapper","id":"CVE-2025-71370","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"picklescan - Remote Code Execution via code.InteractiveInterpreter Detection Bypass","id":"CVE-2025-71371"},"packages":[{"ecosystem":"PyPI","fixed":["0.0.28"],"introduced":["0"],"last_affected":[],"package":"picklescan","purl":null,"source":"GHSA-vr7h-p6mm-wpmh"},{"ecosystem":"PyPI","fixed":["0.0.28"],"introduced":["0"],"last_affected":[],"package":"picklescan","purl":"pkg:pypi/picklescan","source":"GHSA-vr7h-p6mm-wpmh"},{"ecosystem":"PyPI","fixed":["0.0.28"],"introduced":["0"],"last_affected":[],"package":"picklescan","purl":"pkg:pypi/picklescan","source":"PYSEC-2026-4136"}],"prev":{"headline":"picklescan - Unsafe Deserialization via torch.utils.data.datapipes.utils.decoder.basichandlers","id":"CVE-2025-71369"},"products":["picklescan"],"published":"2026-06-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-23","vendors":["picklescan"]},"summary":"Attackers can bypass picklescan detection to execute arbitrary code via malicious pickle files containing unsupported tensor operations.","url":"https://insights.sbomify.com/CVE-2025-71370/"}