CVE-2025-71379 vllm - Regular Expression Denial of Service in Multiple Components

Medium 5.3 Published Updated

Attackers can cause denial of service in vLLM by submitting crafted inputs that trigger catastrophic backtracking in regular expressions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-71379?

CVE-2025-71379 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 20 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

vLLM versions >= 0.6.3 and < 0.9.0 contain multiple regular expression denial of service (ReDoS) vulnerabilities. Several regex patterns — in vllm/lora/utils.py, the phi4mini tool parser, and the OpenAI-compatible serving chat endpoint — are susceptible to catastrophic backtracking. An attacker submitting crafted input with nested or repeated structures can trigger severe CPU consumption and performance degradation, resulting in denial of service.

Weakness: CWE-1333

Which versions are affected by CVE-2025-71379?

2 open source packages ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIFrom 0.6.30.9.0
vllm PyPIFrom 0.6.30.9.0

Products include Vllm Vllm.

How do I fix CVE-2025-71379?

Upgrade vllm to 0.9.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-71379 being exploited?

There is no known exploitation of CVE-2025-71379 in the wild and no public exploit code.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-j828-28rj-hfhp.

Is CVE-2025-71379 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free