{"answers":{"affected":"2 open source packages ship an affected version, including vllm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-71379 in the wild and no public exploit code.","fix":"Upgrade vllm to 0.9.0 or later.","what":"CVE-2025-71379 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 20 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-71379 and fix it if it is affected.\n\nWhat it is: CVE-2025-71379 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 20 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-71379 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vllm (PyPI): affected from 0.6.3; fixed in 0.9.0\n- vllm (PyPI): affected from 0.6.3; fixed in 0.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-71379/ (Markdown: https://insights.sbomify.com/CVE-2025-71379/index.md)","id":"CVE-2025-71379","markdown":"https://insights.sbomify.com/CVE-2025-71379/index.md","name":"CVE-2025-71379","record":{"aliases":["GHSA-j828-28rj-hfhp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM inference library","requires_auth":"low_privilege","summary":"Attackers can cause denial of service in vLLM by submitting crafted inputs that trigger catastrophic backtracking in regular expressions.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"vllm","vendor":"vllm"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"vLLM versions \u003e= 0.6.3 and \u003c 0.9.0 contain multiple regular expression denial of service (ReDoS) vulnerabilities. Several regex patterns — in vllm/lora/utils.py, the phi4mini tool parser, and the OpenAI-compatible serving chat endpoint — are susceptible to catastrophic backtracking. An attacker submitting crafted input with nested or repeated structures can trigger severe CPU consumption and performance degradation, resulting in denial of service.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"vllm - Regular Expression Denial of Service in Multiple Components","id":"CVE-2025-71379","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"vllm:vllm","products":["vllm:vllm"],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"n8n - Arbitrary Command Execution via Execute Command Node","id":"CVE-2025-71380"},"packages":[{"ecosystem":"PyPI","fixed":["0.9.0"],"introduced":["0.6.3"],"last_affected":[],"package":"vllm","purl":null,"source":"GHSA-j828-28rj-hfhp"},{"ecosystem":"PyPI","fixed":["0.9.0"],"introduced":["0.6.3"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"GHSA-j828-28rj-hfhp"}],"prev":{"headline":"picklescan - Remote Code Execution via Undetected cProfile.runctx in Pickle Files","id":"CVE-2025-71378"},"products":["vllm"],"published":"2026-06-20","related":[{"cvss_score":10,"headline":"vLLM Vulnerable to Remote Code Execution via Mooncake Integration","id":"CVE-2025-32444","kev_date_added":null,"published":"2025-04-30"},{"cvss_score":9.8,"headline":"vLLM leaks a heap address when PIL throws an error","id":"CVE-2026-22778","kev_date_added":null,"published":"2026-02-02"},{"cvss_score":9.8,"headline":"vLLM Allows Remote Code Execution via PyNcclPipe Communication Service","id":"CVE-2025-47277","kev_date_added":null,"published":"2025-05-20"},{"cvss_score":9.8,"headline":"Remote Code Execution in vllm-project/vllm","id":"CVE-2024-11041","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.1,"headline":"vLLM: OpenAI auth bypass","id":"CVE-2026-48746","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.1,"headline":"vLLM Allows Remote Code Execution via Mooncake Integration","id":"CVE-2025-29783","kev_date_added":null,"published":"2025-03-19"},{"cvss_score":8.8,"headline":"vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector","id":"CVE-2026-116176","kev_date_added":null,"published":"2026-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-22","vendors":["vllm"]},"summary":"Attackers can cause denial of service in vLLM by submitting crafted inputs that trigger catastrophic backtracking in regular expressions.","url":"https://insights.sbomify.com/CVE-2025-71379/"}