# CVE-2025-71379: vllm - Regular Expression Denial of Service in Multiple Components

> Attackers can cause denial of service in vLLM by submitting crafted inputs that trigger catastrophic backtracking in regular expressions.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** GHSA-j828-28rj-hfhp

## What is CVE-2025-71379?

CVE-2025-71379 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 20 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM versions >= 0.6.3 and < 0.9.0 contain multiple regular expression denial of service (ReDoS) vulnerabilities. Several regex patterns — in vllm/lora/utils.py, the phi4mini tool parser, and the OpenAI-compatible serving chat endpoint — are susceptible to catastrophic backtracking. An attacker submitting crafted input with nested or repeated structures can trigger severe CPU consumption and performance degradation, resulting in denial of service.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2025-71379?

2 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.6.3 | 0.9.0 |
| `vllm` | PyPI | From 0.6.3 | 0.9.0 |

Products: Vllm Vllm.

## How do I fix CVE-2025-71379?

Upgrade vllm to 0.9.0 or later.

## Is CVE-2025-71379 being exploited?

There is no known exploitation of CVE-2025-71379 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71379 and fix it if it is affected.

What it is: CVE-2025-71379 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 20 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-71379 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.6.3; fixed in 0.9.0
- vllm (PyPI): affected from 0.6.3; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71379/ (Markdown: https://insights.sbomify.com/CVE-2025-71379/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71379
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71379
- OSV: https://osv.dev/vulnerability/CVE-2025-71379

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71379/
Summaries are generated and may contain mistakes; the official description above is the record.
