# CVE-2025-71381: Hono - Vary Header Injection in CORS Middleware

> Attackers can inject Vary headers via CORS middleware, causing cache pollution and inconsistent CORS enforcement in shared cache environments.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jun 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-q7jf-gf43-6x6p, MINI-vq54-q62q-3hqm

## What is CVE-2025-71381?

CVE-2025-71381 is a medium-severity vulnerability in Hono, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hono before 4.10.3 contains a flaw in its CORS middleware: when the origin is not set to "*", the middleware copies the Vary header from the incoming request into the response. Because Vary is a response header that should be managed by the server, an attacker can supply arbitrary Vary values that are reflected into the response, potentially causing cache key pollution and inconsistent CORS enforcement in environments that rely on shared caches or proxies.

Weakness: CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2025-71381?

2 open source packages ship an affected version, including hono.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hono` | npm | All versions | 4.10.3 |
| `hono` | npm | All versions | 4.10.3 |

## How do I fix CVE-2025-71381?

Upgrade hono to 4.10.3 or later.

## Is CVE-2025-71381 being exploited?

There is no known exploitation of CVE-2025-71381 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71381 and fix it if it is affected.

What it is: CVE-2025-71381 is a medium-severity vulnerability in Hono, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-71381 in the wild and no public exploit code.

Affected packages and fixed versions:
- hono (npm): affected all versions; fixed in 4.10.3
- hono (npm): affected all versions; fixed in 4.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71381/ (Markdown: https://insights.sbomify.com/CVE-2025-71381/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71381
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71381
- OSV: https://osv.dev/vulnerability/CVE-2025-71381

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71381/
Summaries are generated and may contain mistakes; the official description above is the record.
