CVE-2025-71391 SurrealDB before 2.2.2 Denial of Service via /sql endpoint

High 7.1 Published Updated

Authenticated attackers can crash the SurrealDB database by sending crafted HTTP queries with null bytes to the /sql endpoint.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-71391?

CVE-2025-71391 is a high-severity denial of service vulnerability in Surrealdb Surrealdb, published on 18 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

SurrealDB versions before 2.2.2 contain an uncaught exception vulnerability in the net module that allows authenticated users to crash the database. Attackers can send crafted HTTP queries containing null bytes to the /sql endpoint, causing an unhandled exception that crashes the SurrealDB instance and any dependent applications.

Weakness: CWE-248

Which versions are affected by CVE-2025-71391?

6 open source packages ship an affected version, including surrealdb. It affects 1 product.

PackageAffectedFixed in
surrealdb crates.ioAll versions2.0.5
surrealdb crates.ioAll versions2.0.5
surrealdb crates.ioFrom 2.1.02.1.5
surrealdb crates.ioFrom 2.1.02.1.5
surrealdb crates.ioFrom 2.2.02.2.2
surrealdb crates.ioFrom 2.2.02.2.2

Products include Surrealdb Surrealdb.

How do I fix CVE-2025-71391?

Upgrade surrealdb to a fixed version for your release line: 2.0.5, 2.1.5 or 2.2.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-71391 being exploited?

There is no known exploitation of CVE-2025-71391 in the wild and no public exploit code.

All Surrealdb Surrealdb vulnerabilities

Sources

Also known as GHSA-rq86-9m6r-cm3g, GHSA-x3fg-mm84-q54h.

Is CVE-2025-71391 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free