# CVE-2025-71392: SurrealDB before 2.2.2 SurrealQL Injection via export

> Authenticated users can inject SurrealQL via malicious table names, leading to privilege escalation and root takeover when backups are imported.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Jul 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-ccj3-5p93-8p42

## What is CVE-2025-71392?

CVE-2025-71392 is a critical code injection vulnerability in Surrealdb Surrealdb, published on 18 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

SurrealDB before 2.0.5, 2.1.x before 2.1.5, and 2.2.x before 2.2.2 fails to properly escape table and field names in the command-line export command. An authenticated System User with OWNER or EDITOR roles can create tables or fields with malicious names containing SurrealQL. When a higher-privileged user subsequently imports the exported backup, the injected SurrealQL executes, enabling privilege escalation and root-level takeover of the SurrealDB instance. Applications that let users define custom tables or fields are also exposed to a universal second-order SurrealQL injection even when query parameters are sanitized.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-71392?

6 open source packages ship an affected version, including surrealdb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `surrealdb` | crates.io | All versions | 2.0.5 |
| `surrealdb` | crates.io | All versions | 2.0.5 |
| `surrealdb` | crates.io | From 2.1.0 | 2.1.5 |
| `surrealdb` | crates.io | From 2.1.0 | 2.1.5 |
| `surrealdb` | crates.io | From 2.2.0 | 2.2.2 |
| `surrealdb` | crates.io | From 2.2.0 | 2.2.2 |

Products: Surrealdb Surrealdb.

## How do I fix CVE-2025-71392?

Upgrade surrealdb to a fixed version for your release line: 2.0.5, 2.1.5 or 2.2.2.

## Is CVE-2025-71392 being exploited?

There is no known exploitation of CVE-2025-71392 in the wild and no public exploit code.

## Other vulnerabilities in Surrealdb Surrealdb

- [CVE-2026-63756](https://insights.sbomify.com/CVE-2026-63756/): SurrealDB before 3.1.0 Privilege Escalation via RPC Session Race Condition (critical 9.2)
- [CVE-2026-63747](https://insights.sbomify.com/CVE-2026-63747/): SurrealDB before 3.1.0 Denial of Service via malformed RPC use (high 8.7)
- [CVE-2026-63757](https://insights.sbomify.com/CVE-2026-63757/): SurrealDB before 3.1.0 Session Hijacking via /rpc sessions (high 8.7)
- [CVE-2026-63760](https://insights.sbomify.com/CVE-2026-63760/): SurrealDB before 3.1.0 Denial of Service via JSON Parser (high 8.7)
- [CVE-2023-54366](https://insights.sbomify.com/CVE-2023-54366/): SurrealDB before 1.0.1 Insecure Default Table Permissions (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71392 and fix it if it is affected.

What it is: CVE-2025-71392 is a critical code injection vulnerability in Surrealdb Surrealdb, published on 18 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-71392 in the wild and no public exploit code.

Affected packages and fixed versions:
- surrealdb (crates.io): affected all versions; fixed in 2.0.5
- surrealdb (crates.io): affected all versions; fixed in 2.0.5
- surrealdb (crates.io): affected from 2.1.0; fixed in 2.1.5
- surrealdb (crates.io): affected from 2.1.0; fixed in 2.1.5
- surrealdb (crates.io): affected from 2.2.0; fixed in 2.2.2
- surrealdb (crates.io): affected from 2.2.0; fixed in 2.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71392/ (Markdown: https://insights.sbomify.com/CVE-2025-71392/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71392
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71392
- OSV: https://osv.dev/vulnerability/CVE-2025-71392

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71392/
Summaries are generated and may contain mistakes; the official description above is the record.
