CVE-2025-71393 SurrealDB before 2.2.2 Memory Exhaustion via Nested Functions

Medium 6.0 Published Updated

Authenticated attackers can exhaust server memory by bypassing recursion limits in SurrealDB when scripting is enabled.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-71393?

CVE-2025-71393 is a medium-severity denial of service vulnerability in Surrealdb Surrealdb, published on 18 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

SurrealDB before 2.2.2 with scripting enabled fails to properly enforce recursion limits when native functions contain embedded JavaScript that issues new queries. Authenticated attackers can bypass the recursion limit by chaining native and JavaScript function calls to trigger infinite recursion and exhaust server memory.

Weakness: CWE-674

Which versions are affected by CVE-2025-71393?

6 open source packages ship an affected version, including surrealdb. It affects 1 product.

PackageAffectedFixed in
surrealdb crates.ioAll versions2.0.5
surrealdb crates.ioAll versions2.0.5
surrealdb crates.ioFrom 2.1.02.1.5
surrealdb crates.ioFrom 2.1.02.1.5
surrealdb crates.ioFrom 2.2.02.2.2
surrealdb crates.ioFrom 2.2.02.2.2

Products include Surrealdb Surrealdb.

How do I fix CVE-2025-71393?

Upgrade surrealdb to a fixed version for your release line: 2.0.5, 2.1.5 or 2.2.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-71393 being exploited?

There is no known exploitation of CVE-2025-71393 in the wild and no public exploit code.

All Surrealdb Surrealdb vulnerabilities

Sources

Also known as GHSA-m7rc-8w7m-r9qr, GHSA-w8p8-58rp-4rqp.

Is CVE-2025-71393 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free