# CVE-2025-71394: SurrealDB before 2.2.2 Local File Read via DEFINE ANALYZER

> Authenticated users with elevated privileges can read arbitrary files from the server filesystem via the DEFINE ANALYZER statement.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Jul 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-2cvj-g5r5-jrrg, GHSA-627h-wprw-6cpg

## What is CVE-2025-71394?

CVE-2025-71394 is a low-severity path traversal vulnerability in Surrealdb Surrealdb, published on 18 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

SurrealDB versions before 2.2.2 contain a local file read vulnerability in the DEFINE ANALYZER statement that allows authenticated users to read arbitrary files on the file system. Attackers with root, namespace, or database level privileges can point analyzers to arbitrary file paths and exfiltrate content from two-column tab-separated files.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-71394?

4 open source packages ship an affected version, including surrealdb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `surrealdb` | crates.io | All versions | 2.1.5 |
| `surrealdb` | crates.io | All versions | 2.1.5 |
| `surrealdb` | crates.io | From 2.2.0 | 2.2.2 |
| `surrealdb` | crates.io | From 2.2.0 | 2.2.2 |

Products: Surrealdb Surrealdb.

## How do I fix CVE-2025-71394?

Upgrade surrealdb to a fixed version for your release line: 2.1.5 or 2.2.2.

## Is CVE-2025-71394 being exploited?

There is no known exploitation of CVE-2025-71394 in the wild and no public exploit code.

## Other vulnerabilities in Surrealdb Surrealdb

- [CVE-2025-71392](https://insights.sbomify.com/CVE-2025-71392/): SurrealDB before 2.2.2 SurrealQL Injection via export (critical 9.4)
- [CVE-2026-63756](https://insights.sbomify.com/CVE-2026-63756/): SurrealDB before 3.1.0 Privilege Escalation via RPC Session Race Condition (critical 9.2)
- [CVE-2026-63747](https://insights.sbomify.com/CVE-2026-63747/): SurrealDB before 3.1.0 Denial of Service via malformed RPC use (high 8.7)
- [CVE-2026-63757](https://insights.sbomify.com/CVE-2026-63757/): SurrealDB before 3.1.0 Session Hijacking via /rpc sessions (high 8.7)
- [CVE-2026-63760](https://insights.sbomify.com/CVE-2026-63760/): SurrealDB before 3.1.0 Denial of Service via JSON Parser (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71394 and fix it if it is affected.

What it is: CVE-2025-71394 is a low-severity path traversal vulnerability in Surrealdb Surrealdb, published on 18 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-71394 in the wild and no public exploit code.

Affected packages and fixed versions:
- surrealdb (crates.io): affected all versions; fixed in 2.1.5
- surrealdb (crates.io): affected all versions; fixed in 2.1.5
- surrealdb (crates.io): affected from 2.2.0; fixed in 2.2.2
- surrealdb (crates.io): affected from 2.2.0; fixed in 2.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71394/ (Markdown: https://insights.sbomify.com/CVE-2025-71394/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71394
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71394
- OSV: https://osv.dev/vulnerability/CVE-2025-71394

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71394/
Summaries are generated and may contain mistakes; the official description above is the record.
